[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Search for an entry expands parent

From: Gt Uit
Subject: Re: Search for an entry expands parent
Date: Sat, 18 Jul 2020 11:58:00 +0300

- all
17.07.2020, 07:56, "Gt Uit" <gt3uit@yandex.com>:
17.07.2020, 01:42, "Kyle Meyer" <kyle@kyleam.com>:

Gt Uit writes:

 I recently upgraded to org mode version 9.3.6 and the following
 behavior was introduced: When I search for an entry using C-s, all the
 parent entries and sub-entries are expanded and stay expanded.

 Find in https://imgur.com/a/vzEU1zp screenshots of the newly
 introduced behavior and expected/old behavior.

An image is helpful, and some may follow that link, but it's also useful
to include example Org content and a set of steps to reproduce the
behavior you're describing. Based on that link, something like

--8<---------------cut here---------------start------------->8---
* A
** B
some text
** C
target search
--8<---------------cut here---------------end--------------->8---

And then, with all content folded, 'C-s target'.

With the default settings in Org 9, the result is

    * A
    ** B...
    ** C
    target search

I believe you want the visibility to be like this:

    * A...
    ** C
    target search

You can customize this behavior through org-show-context-detail. It
sounds like you'd prefer `minimal':

    (setf (alist-get 'isearch org-show-context-detail)

  Thanks a lot for the prompt and helpful response. I added the above snippet to the .emacs file and restarted. Did a describe-variable and got the following:
"org-show-context-detail is a variable defined in ‘org.el’.
Its value is
((agenda . local)
(bookmark-jump . lineage)
(isearch . minimal)
(default . ancestors))"
 However, doing a search still expands all the entries. I downgraded to orgmode v 9.3.1 and still got the same results. I tried on a fresh emacs instance with the only entry in it being setting the  org-show-context-detail isearch to minimal and still got the same results (search expands all entries).
  Is it possible that this is a bug? I'd like to note that I am using emacs  v26.3 .
Gt Uit
Updates since my last email:
- Sometimes the first C-s yields intended result (minimal), with
subsequent C-s searches expanding all entries.
- I tried on Emacs 28.0.50 and am getting the same results.
- I tried with emacs -Q and isearch minimal behaves properly!
- I tried a live distribution (Linux Mint 20 Ulyana, same
distribution I am currently using) and isearch minimal behaves
- I tried the following without any success:
+ Remove all emacs related packages and reinstall emacs (via apt)
+ Install emacs from snap.
Now that I have narrowed down the bug to be something local to my
current installation please advise on how to debug/resolve.
Gt Uit

reply via email to

[Prev in Thread] Current Thread [Next in Thread]