[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bugs in the new release of org

From: Samuel Wales
Subject: bugs in the new release of org
Date: Fri, 2 Oct 2020 20:04:33 -0700

a few things are broken for me in the new version of maint.  my
computer use is limited, so i am taking them slowly..

emacs 25.

any hints are welcome.  i am not able to proceed further.


this export does nothing, with no errors or warnings:

  (org-export-to-buffer 'ascii "alpha-org-export-output.txt" nil
'subtree nil 'body-only)

prior to the recent release, it exported.

i tried emacs -Q with C-c C-e A, this said that it was unable to
resolve a link.  however, the link was outside the subtree.  i do not
know why it would look there.  also i do not know why it woul dtry to
resolve a link.  or rather i don't know what that means.

the link seems ok.  it is an org id link.  so why is it erroring?  i
don't know.  does this have anything to do with the errorless
no-result problem i am trying to debug?  i could not be sure.

i also tried edebug, but that quickly exceeds my limits.  i did
unwisely do a few levels, but everything returned nothing.  for
example, the export-as function returned an empty string.

any comments or hints, even small ones, would be appreciated.  i am
not able to debug this.


another broken thing, in case it rings a bell for anybody, is that i
had eldoc set up to emit link target when hovering cursor/pointer.  i
think this uses
help echo.  that stopped working.  if this does not trigger a priori
ideas, i will let it stay broken.

thank you.

The Kafka Pandemic

Please learn what misopathy is.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]