[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: a repeater doesn't increment

From: Nick Dokos
Subject: Re: a repeater doesn't increment
Date: Thu, 22 Jul 2021 17:12:20 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

Jude DaShiell <jdashiel@panix.com> writes:

> Does enough material exist on werg tutorials that document how to get a
> repeater operational?  That or maybe I don't understand repeaters.  Had
> the repeater I tried to use worked correctly it would have advanced the
> original date by 4 weeks when that date got copied down to another cell.
> I selected the whole line including both verticals and perhaps this works
> when only a time stamp is copied.

I may be misunderstanding, but are you trying to fill a column in a table
with dates that are four weeks apart? If so, repeaters have nothing to do
with it (AFAIK). You need `org-table-copy-increment' to be set to 28.

--8<---------------cut here---------------start------------->8---

| date             | foo |
| <2021-07-22 Thu> |     |
| <2021-08-19 Thu> |     |
| <2021-09-16 Thu> |     |
| <2021-10-14 Thu> |     |
| <2021-11-11 Thu> |     |
| <2021-12-09 Thu> |     |

* Code

#+begin_src elisp
(setq-local org-table-copy-increment 28)


: 28

--8<---------------cut here---------------end--------------->8---

Then keep pressing `S-RET' to get the next date.

> On Tue, 20 Jul 2021, Jude DaShiell wrote:
>> I am likely doing this wrong but will describe what has been done.
>> I put an agenda time stamp into a field in test.org and add +4w to the end
>> of the time stamp inside the >.
>> I get on the left of the field column on the vertical character and type
>> control-space to set mark.
>> I move to the end of the field on the > sign and type space and another
>> vertical to close the column entry for that field.
>> Next I do control-c+x+v and am told strings are copied to the kill ring.
>> Next I move down one line and type control-y to yank those strings out of
>> the kill buffer and paste them on that line.
>> When this is done, I expected the time stamp to increment by 4 weeks.
>> What happened was the same information got copied down and it didn't
>> increment.
>> What am I doing wrong?


"There are only two hard problems in computer science: cache
invalidation, naming things, and off-by-one errors." -Martin Fowler

reply via email to

[Prev in Thread] Current Thread [Next in Thread]