[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [BUG] adjacent italic and underline don't render correctly [9.5.1 (9

From: Robert Nikander
Subject: Re: [BUG] adjacent italic and underline don't render correctly [9.5.1 (9.5.1-g36086a @ /Users/rob/.emacs.d/elpa/org-9.5.1/)]
Date: Wed, 22 Dec 2021 10:38:20 -0500

Thank you for checking. I tried to reinstall the package, but it did not help, and it caused another problem where I could not quit emacs.

Details… I ran M-x list-packages, found and deleted my org package, quit emacs. Restarted emacs and I saw I had the builtin org (lower version: 9.4.4) and the bug I reported is gone. I tried reinstalling the 9.5.1 org package (after restarting emacs), and it installed, and then I couldn’t quit emacs without killing it. If I ran my usual quit command (save-buffers-kill-terminal) or tried to quit from the macOS menu, I got this message:

org-clock-kill-emacs-query: Symbol’s function definition is void: org-clocking-buffer

Also the bug I reported is back. 

Maybe I’ll just stick with the builtin org package 9.4.4.  

Am I supposed to somehow delete the builtin one when I install 9.5.1? Here is what the buffer looks like when I hit enter on the installed 9.5.1 package:

— begin paste —
Package org is installed.

     Status: Installed in ‘org-9.5.1/’,
             shadowing a built-in package (unsigned). Delete
    Version: 9.5.1
    Summary: Outline-based notes management and organizer
   Requires: emacs-25.1
   Homepage: https://orgmode.org
   Keywords: outlines hypermedia calendar wp 
 Maintainer: Bastien Guerry <bzg@gnu.org>
     Author: Carsten Dominik <carsten.dominik@gmail.com>
Other versions: 9.5.1 (gnu), 9.4.4 (builtin).
— end paste ---


On Dec 22, 2021, at 9:32 AM, Ihor Radchenko <yantar92@gmail.com> wrote:

Robert Nikander <robert.nikander@icloud.com> writes:

(setq org-hide-emphasis-markers t)

…and the following does not render right. In the first line I see the ‘_’ characters around “underline”, and it doesn’t underline the text.
In the second line, it works correctly. Apparently it needs some intervening text (“foo” in this case). 

The first line should work, no?

— begin example org file —
* Test
Mix /italic/ _underline_.
Mix /italic/ foo _underline_.
— end example org file ---

I am unable to reproduce it on latest main.

Note that I remember this error and I believe that fixed it by reverting
the problematic commit. However, it was before 36086a. I suspect that
you have a mixed installation of Org. Try to remove and re-install Org.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]