[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: org-meta-return / org-insert-heading does not insert new heading in

From: Guillaume MULLER
Subject: Re: org-meta-return / org-insert-heading does not insert new heading in middle of heading even id org-M-RET-may-split-line is set
Date: Thu, 7 Jul 2022 17:52:11 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.9.1

Hi again,

Thanks for your answer and sorry for the duplicate.

I would be glad to help find if/where is the bug.

> Note that '(default . t) is _not_ the correct value. It should be
 '((default . t)). Just in case.

Yes indeed. I had it right in my config. I made the mistake when I copied into 
the email.

> I tried to set org-M-RET-may-split-line to nil first followed by setting
> it to either t or '((default . t)). For both values, I am seeing
> * heading number
> * <>one
> which is expected behavior.

Are you using DoomEmacs or Vanilla Emacs?

More precisely, are you using org-mode "9.6-??-e9da29b6f" as I do? (This is the 
only version that gives me the strange behavior)

> Please, try to reproduce starting from emacs -Q (without Doom).
> See https://orgmode.org/manual/Feedback.html

I've tried several things, but it's not very clear to me how to get/test the 
specific version of org-mode that is comes with doom ("9.6-??-e9da29b6f").

What I tried:

- Getting an as-vanilla-as-possible DoomInstall, by removing my config.org and 
sync'ing Doom. I get the same "9.6-??-e9da29b6f" org version and erroneous 

- Changing the version of org-mode used in Doom, by removing the directory and 
installing the one from MELPA (9.5.4). This gives me the correct behavior for 
org-meta-return, but it breaks too many other things in org to be usable.

- Using "vanilla" "emacs -Q" and running only org "9.6".

  1. I've tried to manually load the org-version that comes with Doom, by 
writing & executing "(add-to-list 'load-path 
"/home/user/.emacs.d/modules/lang/org/lisp/autoload") (load "org")" from 
scratch buffer, then running org-reload
   + but I get org-version 9.3
   + and I can't find a way to edit the "load-path" "variable" to remove the 
native path ("/usr/share/emacs/27.1/lisp/org") from the list (sorry newbie 

  2. I've tried to git clone the org-mode repo in /tmp, but don't see any 
tag/branch that would correspond to a "9.6" version of org.
  + I do see a commit matching e9da29b6f 
    * I've tried to recover the code from this version "git checkout e9da29b6f 
    * Compiled it (make)
    * Opened emacs -Q
    * Wrote and executed "(add-to-list 'load-path "/tmp/org-mode/lisp/") (load 
"org")" in the scratch buffer
    * Ran M-x org-reload
    + But "M-x org-version" still returns "Org mode version 9.5.4", and it 
works as expected

If you have any more hints on how I could setup an environment where I could 
test just org-mode "9.6-??-e9da29b6f" on a raw/vanilla emacs, I vwould be glad 
to test that.

Thanks in advance

Guillaume MULLER

Attachment: OpenPGP_signature
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]