[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: several bugs in latest emacs 21.3 from cvs

From: Kenichi Handa
Subject: Re: several bugs in latest emacs 21.3 from cvs
Date: Mon, 17 Mar 2003 11:35:21 +0900 (JST)
User-agent: SEMI/1.14.3 (Ushinoya) FLIM/1.14.2 (Yagi-Nishiguchi) APEL/10.2 Emacs/21.2.92 (sparc-sun-solaris2.6) MULE/5.0 (SAKAKI)

In article <address@hidden>, Eugeny Korekin <address@hidden> writes:
> 4. pasting of cyrillic letters to xterm with mouse works fine, but
> cyrillic letters does not pasted to multi-gnome-terminal,
> that's strange, cause pasting from any other application
> (for example emacs 21.2) to multi-gnome-terminal works.

Strange.  I've just tried it.  It seems that pasting from
emacs 21.3.50 to multi-gnome-terminal works well, but
pasting from emacs 21.2 to xterm and multi-gnome-terminal

I ran emacs, multi-gnome-terminal, and xterm in the locale
ru_RU.  And for the last two, I explicitely specified a
koi8-r font.

One difference between multi-gnome-terminal and xterm is
that the former requests the selection type STRING to Emacs
but the latter requests the selection type UTF8_STRING.  It
seems that multi-gnome-terminal is not internationalized at

> 5. Pasting of cyrillic letters to emacs doesn't works right
> for any application:

> sample of paste from galeon 1.3.2:

> \x{043D}\x{043E} \x{043D}\x{0435} \x{0443}\x{0447}\x{0438}\x{0442}\x{044B}

> sample of paste from xterm:


Your mail arrived at me in this encoding
        Content-type: text/plain; charset=iso-8859-15
So the characters of the last line are also iso-8859-15, not
cyrillic chars.

Anyway, I also tried and got the following result (I visited

(1-1) paste from galeon to emacs:
  fail (got latin-1 chars instead of something like \x{043D}
  as your case)
(1-2) paste from emacs to galenon
(2-1) paste from galeon to xterm
(2-2) paste from xterm to galeon
(3-1) paste from galeon to 
  fail (got different cyrillic chars)
(3-2) paste from multi-gnome-terminal to galeon
  fail (got different cyrillic chars)

I suspect galeon sends back an incorrect data upon selection
request.  How about your case for (1-2) (2-2) (3-1) (3-2)?

Ken'ichi HANDA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]