[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

dired fails when ls exits with >0

From: Frederik Fouvry
Subject: dired fails when ls exits with >0
Date: Mon, 6 Dec 2004 14:08:53 +0100 (CET)


With emacs -q --no-site-file, opening a directory with an entry that
cannot be stat/lstat'ed (corrupted? ; to do with NFS?), it gives the
error message "Listing directory failed but `access-file' worked" (see
below).  That's rather annoying, as I frequently have to some
directories that have these unfortunate properties.  [I do not know
how such problematic directories can be produced, and hence it is hard
to reproduce the problem itself.  Therefore I hope the description is
convincing enough.]

In Emacs 21.3.1, it works fine: the directory is listed together with
the error message in Dired mode.  The difference seems to be that in
the pretest version of Emacs, an error is raised when
`insert-directory-program' returns non-zero.  In my opinion, this is
an assumption too much.  I would suggest to write a warning instead of
an error, or make triggering an error (in this function) customisable.
This way, the effect of problems over which the user has no control
can be worked around.


Frederik Fouvry

In GNU Emacs (i686-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2004-12-02 on cc.at.coli.uni-sb.de
Distributor `The XFree86 Project, Inc', version 11.0.40201000
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: POSIX
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: address@hidden
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_GB
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: t

Major mode: Lisp Interaction

Minor modes in effect:
  mouse-wheel-mode: t
  menu-bar-mode: t
  unify-8859-on-encoding-mode: t
  utf-translate-cjk-mode: t
  line-number-mode: t

Recent input:
<help-echo> <help-echo> C-x C-f / c o u r s e s <return> 
<help-echo> <help-echo> <help-echo> <help-echo> <menu-bar> 
<help-menu> <report-emacs-bug>

Recent messages:
Loading mwheel...done
(src/emacs -q --no-site-file)
Loading disp-table...done
Loading tooltip...done
Loading image...done
Loading dired...
Loading regexp-opt...done
Loading dired...done
insert-directory: Listing directory failed but `access-file' worked
Loading emacsbug...done

reply via email to

[Prev in Thread] Current Thread [Next in Thread]