[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

OS X: mouse wheel on powerbooks broken, Option modifier

From: David Reitter
Subject: OS X: mouse wheel on powerbooks broken, Option modifier
Date: Sun, 5 Jun 2005 13:34:20 +0100

Forwarding this with a subject line. I can confirm both bugs.


Howard Melman:

I'm using Aquamacs 0.9.2b5 on a new G4 PowerBook running 10.4.1. I find that Option-u doesn't generate a M-u key sequence and therefore doesn't run uppercase-word. I say it doesn't generate a key sequence because if I do C-h c and then type Option-u at the prompt, nothing happens, it's as if I didn't type anything. Works fine for other key combinations (e.g., Option-c).

Also I find the new two finger scrolling on the trackpad doesn't do anything.

Both of these fail in the same way with the latest Carbon Emacs from http://home.att.ne.jp/alpha/z123/emacs-mac-e.html

I'm sure two finger scrolling worked on Panther with earlier builds and I think Option-u worked as well, but am not 100% sure.


In GNU Emacs (powerpc-apple-darwin8.1.0)
 of 2005-06-01 on madonna - Aquamacs Distribution 0.9.2 beta-5
Distributor `Apple Computers' version (10 4 1) .
configured using `configure '--without-x' '--prefix=/usr/local''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: nil
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: nil

Major mode: Emacs-Lisp

Minor modes in effect:
  eldoc-mode: t
  outline-minor-mode: t
  iswitchb-mode: t
  which-function-mode: t
  msb-mode: t
  show-paren-mode: t
  delete-selection-mode: t
  pc-selection-mode: t
  cua-mode: t
  aquamacs-tool-bar-mode: t
  smart-frame-positioning-mode: t
  recentf-mode: t
  encoded-kbd-mode: t
  osx-key-mode: t
  mouse-wheel-mode: t
  tooltip-mode: t
  auto-compression-mode: t
  menu-bar-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  unify-8859-on-encoding-mode: t
  utf-translate-cjk-mode: t
  column-number-mode: t
  line-number-mode: t
  transient-mark-mode: t
  next-error-follow-minor-mode:  Fol
  view-mode: t

Recent input:
C-x C-f d o c SPC f i SPC c r a SPC SPC <return> C-f C-f M-f M-f M-f M-f M-f M-f M-f M-f M-f M-f M-f H-u H-a C-h c H-c C-h k H-c C-z k <down-mouse-1> <mouse-movement> <mouse-1> C-x k <return> C-a C-h c <menu-bar> <options> <oneonone> C-h f t o g g l e - o n <tab> <return> <help-echo> <down-mouse-1> <mouse-2> <down-mouse-1> <mouse-1> <switch-frame> <down-mouse-1> <mouse-1> <down-mouse-1> <mouse-1> <menu-bar> <help-menu> <report-emacs-bug>

Recent messages:
For information about the GNU Project and its goals, type C-h C-p.
Mark set [2 times]
H-c runs the command cua-copy-region
<menu-bar> <options> <oneonone> runs the command toggle-oneonone
Note: file is write protected
Loading outline...done
Loading eldoc...done
View mode: type C-h for help, h for commands, q to quit.
Loading font-lock...done
Loading jit-lock...done

reply via email to

[Prev in Thread] Current Thread [Next in Thread]