[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emms-time-display-style

From: Yoni Rabkin
Subject: Re: emms-time-display-style
Date: Thu, 13 Oct 2022 18:31:19 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.2 (gnu/linux)

"6ausoft@gmail.com" <6ausoft@gmail.com> writes:

> Thank you for prompt response!
> I tried on 3 different machines and different emacs distributions to
> no avail.
> I tried gnu, melpa, git emms package - every time I get only counter
> progressing as if the variable "Emms Playing Time Display Short P"
> was set, but it is not.
> I don't even get the counter of a style like "01:23 / 05:48" but only
> "01:23"
> [cid]                                                                         
>               >
> Here's screen:
> Playing time style is set to "downtime" but the counter format stays
> the same ( "01:23")  or in the case above ("00:09")
> [cid]   
> Any advice?
> regards!
> On 12.10.2022 22:38, Yoni Rabkin wrote:
>     "6ausoft@gmail.com" <6ausoft@gmail.com> writes:
>         Hallo!
>         I've been struggling for a while with getting the proper time display
>         in emms and what I'm always getting is simply track time counter
>         progressing (eg."01:20") not even the style of "01:30/4:20". Tried
>         customize-group emms and setting the "downtime" value but it didn't
>         work as didn't "bar" option.
>         Tried spacemacs, doom emacs, vanilla - for no success.
>         What am I doing wrong? Any suggestions appreciated.
>         My emms config is like this:
>         (add-to-list 'load-path (concat user-emacs-directory "emms-git/"))
>         (load "emms")
>     Emms is distributed via ELPA. I would warmly recommend installing it via
>     "M-x list-packages"
>     We try to keep the Savannah git repo clean, but that is where
>     development happens. If you use Emms from there you will occasionally
>     have stuff broken (unless you pull only from the latest tag.) If you
>     aren't doing Emms development, I would recommend installing and updating
>     Emms as an ELPA package instead.
>     All that said, this shouldn't be where your issue is. A playing timer
>     should appear if your setup is as simple as:
>     "(emms-all)
>     (emms-default-players)"
>         (use-package emms-setup
>          :init
>          (add-hook 'emms-player-started-hook 'emms-show)
>          (setq emms-show-format "Playing: %s")
>           config
>         (emms-standard)
>         (emms-default-players))
>         (require 'emms-setup)
>         (emms-all)
>         (emms-default-players)
>     `emms-standard' is obsolete (has been marked as obsolete since Emms
>     4.1), and in any case, calling `emms-all' afterward makes it moot.
>     This is everything you need in order for Emms to display a timer. If it
>     doesn't work at this point, we need to do more debugging.
>         (emms-mode-line 1)
>         (require 'emms-playing-time)
>     `emms-all' calls (require 'emms-playing-time), so no need for this either.
>         (emms-playing-time 1)
>         (setq emms-source-file-default-directory "~/Music/"
>               emms-playlist-buffer-name "*Music*"
>               emms-info-asynchronously t
>               emms-source-file-directory-tree-function
>         'emms-source-file-directory-tree-find)
>         (require 'emms-playing-time);
>     ...and definitely no need to call it again.
>         (setq emms-playing-time-display-short-p nil)
>         (setq emms-playing-time-style 'downtime)
>     Please try the above simple, two-line setup on an ELPA install, and tell
>     us if it works, and we'll go from there.

There may be nothing to display. Which is to say, you may have no info

Make sure that the cache is enabled. This should be the default, but we
are being careful here:
(emms-cache 1)

Them make sure that you have a working info function:
(setq emms-info-functions '(emms-info-native))

Then load a playlist and see that you are getting the track, artist,
album and etc., and not just a bunch of filenames. This means that you
have the track info (such as the total playing time) and that should
also be in stored in the cache.

If you are still just getting filenames, then try one of the other info
functions (the other info functions require installing the appropriate
command-line tool, for example emms-info-exiftool requires exiftool to
be present on the system.)

Then try again and see where we get to.

   "Cut your own wood and it will warm you twice"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]