[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emms-time-display-style

From: address@hidden
Subject: Re: emms-time-display-style
Date: Sat, 15 Oct 2022 14:20:36 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.3.2

On 14.10.2022 20:53, Yoni Rabkin wrote:
"6ausoft@gmail.com" <6ausoft@gmail.com> writes:

After adding to config those lines:

(emms-cache 1)
(setq emms-info-functions '(emms-info-native))

it looks like this:


M-x emms-show-all     gives:


I also installed exiftool, actually  "apt install exiftool" installed
libimage-exiftool-perl  (I'm on Debian testing)

And the time counter stays unchanged - no negative countdown despite
'downtime' style enabled.


On 14.10.2022 00:31, Yoni Rabkin wrote:

    "6ausoft@gmail.com" <6ausoft@gmail.com> writes:
        Thank you for prompt response!
        I tried on 3 different machines and different emacs distributions to
        no avail.
        I tried gnu, melpa, git emms package - every time I get only counter
        progressing as if the variable "Emms Playing Time Display Short P"
        was set, but it is not.
        I don't even get the counter of a style like "01:23 / 05:48" but only
        [cid]                                                                                       >
        Here's screen:
        Playing time style is set to "downtime" but the counter format stays
        the same ( "01:23")  or in the case above ("00:09")
        Any advice?
        On 12.10.2022 22:38, Yoni Rabkin wrote:
            "6ausoft@gmail.com" <6ausoft@gmail.com> writes:
                I've been struggling for a while with getting the proper time display
                in emms and what I'm always getting is simply track time counter
                progressing (eg."01:20") not even the style of "01:30/4:20". Tried
                customize-group emms and setting the "downtime" value but it didn't
                work as didn't "bar" option.
                Tried spacemacs, doom emacs, vanilla - for no success.
                What am I doing wrong? Any suggestions appreciated.
                My emms config is like this:
                (add-to-list 'load-path (concat user-emacs-directory "emms-git/"))
                (load "emms")
            Emms is distributed via ELPA. I would warmly recommend installing it via
            "M-x list-packages"
            We try to keep the Savannah git repo clean, but that is where
            development happens. If you use Emms from there you will occasionally
            have stuff broken (unless you pull only from the latest tag.) If you
            aren't doing Emms development, I would recommend installing and updating
            Emms as an ELPA package instead.
            All that said, this shouldn't be where your issue is. A playing timer
            should appear if your setup is as simple as:
                (use-package emms-setup
                 (add-hook 'emms-player-started-hook 'emms-show)
                 (setq emms-show-format "Playing: %s")
                (require 'emms-setup)
            `emms-standard' is obsolete (has been marked as obsolete since Emms
            4.1), and in any case, calling `emms-all' afterward makes it moot.
            This is everything you need in order for Emms to display a timer. If it
            doesn't work at this point, we need to do more debugging.
                (emms-mode-line 1)
                (require 'emms-playing-time)
            `emms-all' calls (require 'emms-playing-time), so no need for this either.
                (emms-playing-time 1)
                (setq emms-source-file-default-directory "~/Music/"
                      emms-playlist-buffer-name "*Music*"
                      emms-info-asynchronously t
                (require 'emms-playing-time);
            ...and definitely no need to call it again.
                (setq emms-playing-time-display-short-p nil)
                (setq emms-playing-time-style 'downtime)
            Please try the above simple, two-line setup on an ELPA install, and tell
            us if it works, and we'll go from there.
    There may be nothing to display. Which is to say, you may have no info
    Make sure that the cache is enabled. This should be the default, but we
    are being careful here:
    (emms-cache 1)
    Them make sure that you have a working info function:
    (setq emms-info-functions '(emms-info-native))
    Then load a playlist and see that you are getting the track, artist,
    album and etc., and not just a bunch of filenames. This means that you
    have the track info (such as the total playing time) and that should
    also be in stored in the cache.
    If you are still just getting filenames, then try one of the other info
    functions (the other info functions require installing the appropriate
    command-line tool, for example emms-info-exiftool requires exiftool to
    be present on the system.)
    Then try again and see where we get to.
If you are on a track in the playlist, and you evaluate:
(emms-playlist-track-at (point))

Do you see an `info-playing-time' in the output association list?

Is this the same if you reset the cache (emms-cache-reset), re-load the

I also assume that this happens with all different albums and tracks,
and not those specific files?

P.S. Please bottom-post.

I think, we've found the culprit:

After installing tinytag and changing info function to

(setq emms-info-functions '(emms-info-tinytag))

and clearing the cache I go the message that program python couldn't be found so  I linked symbolically /usr/bin/python to /usr/bin/python3 and then the tag information was loaded and eventually the timer started working as expected!

After clearing the cache and changing back to  (setq emms-info-functions '(emms-info-native))  again getting only file paths instead of tags and timer only progressing (01:34).

One and the same music album loaded with (emms-playlist-track-at (point)) gets filepaths and timer progressing while loaded after changing config to (setq emms-info-functions '(emms-info-tinytag)) gets tags and timer functioning properly.

On my laptop I installed exiftool from exiftool.org and managed to sort it out as well after adding (setq emms-info-functions '(emms-info-exiftool))

Thanks for Your help!


I'm not so proficient in emacs yet (not a programmer) so explain me please how to evaluate (emms-playlist-track-at (point)) while cursor is on the track in the playlist buffer? After pasting this line to playlist buffer and C-x C-e it evaluates to nil. When pasted to scratch buffer I did the same thing and I got "not EMMS playlist buffer". In M-x functions it can't be found as well.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]