[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: build fails on MacOS/MachO: not ELF or COFF

From: Niobos
Subject: Re: build fails on MacOS/MachO: not ELF or COFF
Date: Mon, 11 May 2020 18:52:37 +0000
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:68.0) Gecko/20100101 Thunderbird/68.8.0

Hi Luca,

On 11/05/2020 19:50, Luca Saiu wrote:
> On 2020-05-11 at 17:13 +0000, Niobos wrote:
>> For the niobos branch (d43116ba9a39d093fd7b3c60ebda33939372a11c), it
>> works a bit better:
>> the build (`make`) succeeds, but the testsuite (`make check`) fails.
>> What is strange is that the testsuite fails in several different ways:
>> The first `make check` fails to compile.
> In file included from example-vms/jitterlisp/jitterlisp-ast.c:23:
> In file included from ./example-vms/jitterlisp/jitterlisp-ast.h:28:
> In file included from ./example-vms/jitterlisp/jitterlisp.h:53:
> ./example-vms/jitterlisp/jitterlisp-eval-vm.h:27:10: fatal error: 
> 'jitterlispvm-vm.h' file not found
> So the jitter executable generating a C file did not do its job.  I
> suspect that the problem may be a dirty build directory.  The makefile
> should handle dependency correctly, even with parallel builds.  You did
> generate jitterlispvm-vm.h :
>   bin/jitter \
>             "./example-vms/jitterlisp/jitterlisp.jitter" \
>             --output "./example-vms/jitterlisp/" \
>             --template-directory="./templates/"
> I cannot really explain this but I suspect something is grossly wrong
> with code generation; mixing generated files from different builds,
> perhaps.

I removed the jitter directory and re-cloned it before checking out the
niobos-branch. Or at least, I thought I did. I wanted to double-check
that, and can't reproduce my earlier results... This makes me doubt my
sanity, since I *did* reproduce this before my previous mail in order to
log the output with `tee`...

Anyway, `make check` now "works" in the sense that it actually tests
things, but the tests still fail (or skip, which I'll ignore).

> The test suite is heavyweight and it is normal that it takes a lot of
> time, but zero passes is absolutely not normal.  Does every test case
> time out ?  Do you see them all failing after a fixed number of seconds,
> maybe 3?

If I run `make check` a second time (I'm guessing that this will re-run
the actual tests, while re-using the preparations), it completes in 38
seconds for 318 failed tests. This averages at 120ms per test. By my
count, I counted around 1 second for 8 failed tests + 8 skips, so these
two numbers are close enough.

So they all seem to fail after approximately the same time, but way less
than 3 seconds.

> Can you please send me a tarball of your tests/ build subdirectory?
> On my machine
>   tar c tests/ | xz -9 | wc -c
> shows about 3MB.  Since half of your testcases is disabled your tarball
> size should be more or less halved as well.

My tests-directory is around 8.7MB, but it compressed quite nicely to
51KB, so I've attached it here.

Just to be sure, I've also re-did the test with `make -j1` and `make -j1
check`. That took forever, but got the same results.

Let me know what next steps I can take to help you forward with this,

Attachment: tests.tar.xz
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]