[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ESPResSo] Re: Slinky chain : i.e. polymer with fixed bond length which

From: Christopher Jesudason
Subject: [ESPResSo] Re: Slinky chain : i.e. polymer with fixed bond length which does not interact with neibouring bonds
Date: Wed, 22 Aug 2007 03:36:58 -0700 (PDT)

Dear Olaf,
Thank you for your conversation concerning
Your comments  will be noted. Another specific
Suppose I wish to set up a polymer system of n
monomers, each charge q which has only a fixed bond
length l without a harmonic bond interaction; this
means a type of constraint dynamics where the total
length of the polymer chain is (n-1)*l no matter what
is the temperature. It is like a slinky chain . How
can this be done with your code? The constraint method
whiCh you mention seems to speak of surface
interactions only. How is a slinky chain set up?  
--- Olaf Lenz <address@hidden> wrote:

> Hash: RIPEMD160
> Hello!
> Christopher Jesudason wrote:
> > 1) The thermostat problem was solved here by using
> > another myconfig.h file , which means there are
> > internal clashes in the headers.
> Ok, fine that you have solved the problem. Would you
> mind telling us,
> how you solved it? Was the problem that you had
> activated the ROTATION
> feature which added additional degrees of freedom?
> If so, we will add
> something to the documentation.
> Your mailings tend to describe your problems in a
> very general way, but
> to leave out the important details, like the code
> that you used to
> actually measure the temperature, the myconfig-file,
> the actual solution
> that you came up with, etc.
> This usually leaves us to do some guesswork what
> your problem actually
> might be, which might very much delay a reply.
> I would recommend to read the following to avoid
> this kind of problems
> in the future:
> > 2) The checkpoint_set read and write could not
> work;
> > on changing the myconfig defining External Forces,
> it
> > could read, but  not properly because it could not
> > integrate since one of the particles was said to
> be
> > outside the box.
> Personally, I always use blockfiles, and I have
> never used checkpoints
> so far. Anyway, again I have to do some guesswork,
> or otherwise to ask
> for more details. I guess, that you have written a
> checkpoint using an
> ESPResSo executable that did not have
> EXTERNAL_FORCES activated, and
> then you tried to read the same checkpoint with an
> ESPResSo executable
> that had it activated? And the integration command
> then stopped because
> of the aforesaid error? Does that describe your
> problem?
> >(This occur ed even with the
> > invalidate command which was so strangely
> described
> > that I could not really understand it)
> Indeed, I noticed that also, and it is one of the
> things-to-do on the
> documentation.
> Cheers
>       Olaf
> Version: GnuPG v1.4.2 (GNU/Linux)
> Comment: Using GnuPG with SUSE -
> dmtS7U+X/12bEoDidNoAWgE=
> =U2M+

Looking for a deal? Find great prices on flights and hotels with Yahoo! 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]