[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ESPResSo] MPI issue

From: Tristan Bereau
Subject: [ESPResSo] MPI issue
Date: Tue, 02 Oct 2007 19:17:40 -0400
User-agent: Thunderbird (X11/20070801)


I'm having some issue getting OpenMPI to work with ESPResSo correctly.
Let me be a little more precise: I am able to start a run using OpenMPI,
everything works fine, except that it's doing N times the same
simulation! The output file I get has N times the same thing written,
and the time it takes to do a run using 1 processor is equal to a run
using more of them.

By the way, I have the last release of ESPResSo, and I downloaded
OpenMPI very recently (only a few weeks ago)..

So I tried reinstalling ESPResSo, to make sure I had the mpi feature
setup correctly, unsuccessfully.

The command I'm using to run a job is:

mpirun -np 4 ~/Espresso/obj-XXX/Espresso_bin my_script.tcl

It doesn't look like MPI is not setup correctly: I tested it with a
small MPI-based "hello-world" application, which worked. (Basically, the
master node sends "hello-world" to any slave node, and these print the
string on the screen.)

Finally, when I launch the 'top' application during a run, I can see my
N processors running at ~100% use.

I know it looks really strange, I just wanted to share my thoughts, just
in case I'm doing something obviously dumb...



reply via email to

[Prev in Thread] Current Thread [Next in Thread]