[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ESPResSo] parallel computing

From: Ahmad A. J. Agung
Subject: Re: [ESPResSo] parallel computing
Date: Sun, 8 Aug 2010 02:58:04 -0700 (PDT)

Hi Mikheil,

I see your LAM installation is in /usr/local/lam folder. Try to install ESPResSo with this:

../configure-ac --with-mpi=lam CPPFLAGS="-I/usr/local/lam/include/ -I(your TCL include-folder)" LDFLAGS= "-L/usr/local/lam/lib -L(your TCL lib-folder)" LD_LIBRARY_PATH="/usr/local/lam/lib:(your TCL lib-folder)"

Set the (your TCL include-folder) and (your TCL lib-folder) according to where your TCL is installed, with the form analogous to how the lam folder was declared in each flag. You can make a trial with OpenMPI also, but it is safer to install one MPI program at a time.

FMIIW, Good Luck,


Message: 1
Date: Sat, 7 Aug 2010 16:44:10 -0400
From: Mikheil Azatov <address@hidden>
Subject: Re: [ESPResSo] ESPResSo Digest, Vol 39, Issue 2
To: address@hidden
Content-Type: text/plain; charset="windows-1252"

Thanks Aang and Olaf,

I uninstalled openmpi and reinstalled lam 7.1.4. I still have the problem
and it looks like you were right Aang. The error looks like this:

../ghosts.h:76:17: error: mpi.h: No such file or directory
In file included from ../cells.h:54,
                from ../thermostat.h:24,
                from ../energy.h:17,
                from ../initialize.c:24:
../ghosts.h:138: error: expected specifier-qualifier-list before ?MPI_Comm?
In file included from ../pressure.h:90,
                from ../thermostat.h:25,
                from ../energy.h:17,
                from ../initialize.c:24:

I attached config.log's of both Espresso(from the obj-Core-pc-linux
directory) and Lam installation. I was not sure which of the config.log's
from the lam directory to send because there were a lot of them in different
folders. So I sent you the one that was in the top directory( i.e. directly
in lam ). Let me know if I sent the right things :)

Hope you can figure out the error,
It's my first week reading about parallel computing so I'm very new to this
University of Maryland

On Sat, Aug 7, 2010 at 12:45 AM, Ahmad A. J. Agung <address@hidden>wrote:

> Hi,
> I might be wrong, but in my experience, it could happen if your MPI library
> (ie. LAM or OpenMPI library) is not in your environment path. If you still
> face the same problem, you may send me the config.log of your MPI and
> Espresso installation. I will try to help.
> Regards,
> Aang
> ------------------------------
> *From:* "address@hidden" <
> address@hidden>
> *To:* address@hidden
> *Sent:* Thu, August 5, 2010 6:02:02 PM
> *Subject:* ESPResSo Digest, Vol 39, Issue 2
> Send ESPResSo mailing list submissions to
>    address@hidden
> To subscribe or unsubscribe via the World Wide Web, visit
> or, via email, send a message with subject or body 'help' to
>    address@hidden
> You can reach the person managing the list at
>    address@hidden
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of ESPResSo digest..."
> Today's Topics:
>  1. parallel computing (Mikheil Azatov)
> ----------------------------------------------------------------------
> Message: 1
> Date: Wed, 4 Aug 2010 11:16:29 -0400
> From: Mikheil Azatov <address@hidden>
> Subject: [ESPResSo] parallel computing
> To: address@hidden
> Message-ID:
>    <address@hidden>
> Content-Type: text/plain; charset="iso-8859-1"
> Hi,
> I'm very new to parallel computing and know very little about it so far. I
> installed lam 7.1.4 on my computer and tried building espresso
> (--with-mpi=MPI option) but i got a lot of errors like this:
> maggs.c:(.text+0x190be): undefined reference to `ompi_mpi_comm_world'
> maggs.c:(.text+0x190e4): undefined reference to `MPI_Irecv'
> maggs.c:(.text+0x19109): undefined reference to `ompi_mpi_comm_world'
> maggs.c:(.text+0x1953c): undefined reference to `ompi_mpi_comm_world'
> maggs.c:(.text+0x19542): undefined reference to `ompi_mpi_op_sum'
> maggs.c:(.text+0x19547): undefined reference to `ompi_mpi_double'
> maggs.c:(.text+0x19561): undefined reference to `MPI_Allreduce'
> maggs.c:(.text+0x198e8): undefined reference to `ompi_mpi_comm_world'
> maggs.c:(.text+0x198ee): undefined reference to `ompi_mpi_op_max'
> maggs.c:(.text+0x198f3): undefined reference to `ompi_mpi_double'
> maggs.c:(.text+0x1990d): undefined reference to `MPI_Allreduce'
> maggs.c:(.text+0x19ca7): undefined reference to `ompi_mpi_comm_world'
> maggs.c:(.text+0x19cad): undefined reference to `ompi_mpi_op_sum'
> maggs.c:(.text+0x19cb2): undefined reference to `ompi_mpi_double'
> maggs.c:(.text+0x19cbc): undefined reference to `MPI_Allreduce'
> maggs.o: In function `Maggs_init':
> maggs.c:(.text+0x1a3c7): undefined reference to `ompi_mpi_comm_world'
> maggs.c:(.text+0x1a3cd): undefined reference to `ompi_mpi_op_sum'
> maggs.c:(.text+0x1a3d2): undefined reference to `ompi_mpi_double'
> maggs.c:(.text+0x1a3dc): undefined reference to `MPI_Reduce'
> maggs.o: In function `prepare_surface_planes':
> maggs.c:(.text+0x4915): undefined reference to `MPI_Type_commit'
> I also tried installing openmpi but got the same...
> I was wondering if anyone could help me to make parallel computing work, or
> maybe show me the manual of how to do this. Any help would be really
> appreciated because I don't even know where to start.
> I was thinking first to make both CPU's on my computer work together and
> then try running on several computers.
> Thanks a lot,
> Mikheil Azatov
> University of Maryland
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]