[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ESPResSo] Compilling ESPResSo in Parallel

From: Salvador Herrera Velarde
Subject: [ESPResSo] Compilling ESPResSo in Parallel
Date: Sun, 29 Aug 2010 10:19:23 -0500

After compiling successfully a serial version of ESPResSo, I am trying to compile a parallel version in a system with the following characteristics:
Linux x86_64
System:  Fedora release 13 (Goddard)
KDE:  4.4.5 (KDE 4.4.5)
Intel(R) Core(TM) i7 CPU 860 @ 2.80GHz
Speed:  2,794.00 MHz
Cores:  8

I tried with the next command:
/home/Chava/Chava2010/ESPResSo/espresso-2.1.5/configure --with-myconfigure=chava-config.h --with-mpi=openmpi  LDFLAGS="-L/usr/lib64/openmpi/lib"

But when I type "make",  the compilation crashes with the following message:
/home/Chava/Chava2010/ESPResSo/espresso-2.1.5/ghosts.h:76:17: error: mpi.h: No such file or directory
In file included from /home/Chava/Chava2010/ESPResSo/espresso-2.1.5/cells.h:54,
                 from /home/Chava/Chava2010/ESPResSo/espresso-2.1.5/thermostat.h:24,
                 from /home/Chava/Chava2010/ESPResSo/espresso-2.1.5/energy.h:17,
                 from /home/Chava/Chava2010/ESPResSo/espresso-2.1.5/initialize.c:24:
/home/Chava/Chava2010/ESPResSo/espresso-2.1.5/ghosts.h:138: error: expected specifier-qualifier-list before ‘MPI_Comm’

I have the following paths but I don't know how the include them in the command:

Besides, I tried to source the mpi.h file in  .bashrc => source /usr/include/openmpi-x86_64/mpi.h/     But I did'n work.

Any help or suggestion would be greatly appreciated.

Thanks a lot,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]