[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ESPResSo-users] Compilation ESPResSo cluster

From: Salvador H-V
Subject: [ESPResSo-users] Compilation ESPResSo cluster
Date: Fri, 8 Mar 2013 15:05:56 -0600

Dear All,

I am trying to compile ESPResSo in a small cluster. But I run into some troubles.  
The cluster runs rocks cluster 6.0. It is composed of one master and five slaves nodes. Each slave node has two cores.

I have two different but related problems.

i) I tried to compile ESPResSo as a root in the folder: /opt/.

This folder has already many applications:
 bio         condor   eclipse   fftw-3.3.3  gridengine  iozone  maven   mpi-tests  pdsh  pxeflash  rocks   stream  SUNWhpc  tomcat-5.0.30  tomcat-6.0.14
chkrootkit  confuse  ESPResSo  ganglia     intel       iperf   mpich2  openmpi    perl  python    sqlite  sun-ct  tomcat   tomcat-5.5.17  tripwire

 But when I try run ESPResSo as a normal user,  I got the following message

mpirun was unable to launch the specified application as it could not access
or execute an executable:
Executable: ./Espresso" 

To launch my jobs via qsub, I created either a symbolic link to the ESPResSo executable or specifying the full path and used a "",  that looks like:

#$ -cwd
#$ -j y
#$ -S /bin/bash

/opt/openmpi/bin/mpirun -n 2 ./Espresso < Mixt_Colloids.tcl

ii) My second problem is related with the number of processors that ESPResSo recognizes during compilation.
Because of the problem stated above, I decided to compile ESPResSo as a normal user in my home. 
I successfully compile it, and I able to run serial and parallel jobs that uses a number of processors EQUAL to the number of cores in each node.

If I try to run a single job with say 8 processors, thus  ESPResSo runs in parallel in one single node! 
It does not use the 8 available cores.

Checking the config.log file, I found the following lines:
configure:7874: checking the number of available CPUs
configure:7895: result: 2

So, I was wondering if anybody has experience with rocks clusters, where is the right place to compile ESPResSo as a root to allow normal users to launch jobs? and How I can compile ESPResSo in order to run in all available nodes (and cores)?

I would appreciate any help or suggestion.

As always... Thanks a lot for your time and help!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]