[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ESPResSo-users] FFTW not found

From: Chandan Choudhury
Subject: [ESPResSo-users] FFTW not found
Date: Mon, 9 Dec 2013 20:02:43 +0530

Dear espresso users,

I downloaded the espresso 3.2.0 package and while trying to compile FFTW is not found :

*         Checking for required tools and libraries            *
checking for libtcl8.6... no
checking for libtcl8.5... yes
checking for tcl.h... yes
checking whether to use FFTW... guess
checking for library containing fftw_plan_many_dft... no
configure: WARNING: FFTW3 not found. Some features will not be available!
checking whether to use CUDA... guess
checking for nvcc... /usr/local/cuda/bin/nvcc
checking for cudaGetDevice in -lcudart... yes
checking for cufftPlan3d in -lcufft... yes
checking whether CUDA compiles... yes
checking whether CUDA runs... no
configure: WARNING: cannot run CUDA code. Some features will not be available!
*                   Configuration summary                      *
platform detected       = x86_64-unknown-linux-gnu
package version         = 3.2.0
development sources     = no

compiler                = mpicc -std=gnu99
linker                  =
c compiler flags        = -Wall -O5
c preprocessor flags    = -I/opt/apps/tcl/861/include/
linker flags            = -L/opt/apps/tcl/861/lib
libraries               = -ltcl8.5  -lm
using debug flags       =
using profiling flags   =
inline                  =

Tcl version             = tcl8.5
Tk version              = none
FFTW                    = no
efence                  = no

Other settings
local config header     = myconfig.h
installation prefix     = /opt/apps/espresso/320
number of test tasks    = 8
mympiexec               = /opt/untar/espresso-3.2.0/
mpiexec                 = /opt/openmpi-1.6/bin/mpiexec
pdflatex                = /usr/bin/pdflatex
makeindex               = /usr/bin/makeindex
bibtex                  = /usr/bin/bibtex
doxygen                 = /usr/bin/doxygen
dot                     = /usr/bin/dot
python                  = /usr/bin/python -B

CUDA disabled or not supported.

The bashrc contain the following lines:
export LD_LIBRARY_PATH=/opt/apps/fftw/3.3.3/single/lib64:$LD_LIBRARY_PATH
export PATH=/opt/apps/fftw/3.3.3/single/bin:$PATH
export LDFLAGS="-L/opt/apps/fftw/3.3.3/single/lib64"
export CPPFLAGS="-I/opt/apps/fftw/3.3.3/single/include/"
export LD_LIBRARY_PATH=/opt/openmpi-1.6/lib:$LD_LIBRARY_PATH
export PATH=/opt/openmpi-1.6/bin:$PATH
export LDFLAGS="-L/opt/openmpi-1.6/lib"
export CPPFLAGS="-I/opt/openmpi-1.6/include/"

export LD_LIBRARY_PATH=/opt/apps/tk/861/lib64:$LD_LIBRARY_PATH
export PATH=/opt/apps/tk/861/bin:$PATH
export LDFLAGS="-L/opt/apps/tk/861/lib64"
export CPPFLAGS="-I/opt/apps/tk/861/include/"
export LD_LIBRARY_PATH=/opt/apps/tcl/861/lib:$LD_LIBRARY_PATH
export PATH=/opt/apps/tcl/861/bin:$PATH
export LDFLAGS="-L/opt/apps/tcl/861/lib"
export CPPFLAGS="-I/opt/apps/tcl/861/include/"

The FFTW I tried to compile is 3.3.3 single precision.

I have source the /etc/bash.bashrc before compiling, but the problem is not solved. Kindly help.


Chandan kumar Choudhury
NCL, Pune

reply via email to

[Prev in Thread] Current Thread [Next in Thread]