[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ESPResSo-users] Espressomd-users Digest, Vol 39, Issue 30

From: Iveta Jancigova
Subject: Re: [ESPResSo-users] Espressomd-users Digest, Vol 39, Issue 30
Date: Mon, 03 Feb 2014 09:03:59 +0100
User-agent: Internet Messaging Program (IMP) H3 (4.3.7)

Hi Markus,

it looks like your simulation is not using the object_in_fluid.tcl script.

First thing to check would be the scripts folder in your espresso working directory. The object_in_fluid.tcl should be located there. If it's not, that must be some compilation problem.

If it is there and still not working with your simulation, pls, try including it directly in the simulation ("source path/object_in_fluid.tcl" before using any oif commands ... or just "source object_in_fluid.tcl" if you make a local copy of the object_in_fluid.tcl). If this helps, it means your espresso is not accessing the scripts folder.

One more thing that is unrelated to this issue, but related to your original message: for the tutorial to run, you need to also have the LB_BOUNDARIES feature compiled in.


----- Správa od address@hidden ---------
     Dátum: Fri, 31 Jan 2014 09:49:40 -0500
        Od: address@hidden
Odpovedať na: address@hidden
   Predmet: Espressomd-users Digest, Vol 39, Issue 30
       Pre: address@hidden

Send Espressomd-users mailing list submissions to

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to

You can reach the person managing the list at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Espressomd-users digest..."

Today's Topics:

   1. Tutorial: Object in Fluid (Wink, Markus)


Message: 1
Date: Fri, 31 Jan 2014 14:49:08 +0000
From: "Wink, Markus" <address@hidden>
To: "'address@hidden'" <address@hidden>
Subject: [ESPResSo-users] Tutorial: Object in Fluid
Content-Type: text/plain; charset="us-ascii"

Hello everybody,

I have a problem in running the tutorial Object-in-fluid tcl-script. Whenever I call "oif_init" I get the error message:

"error in startup script: invalid command name "oif_init"
    while executing
    (file "simulation.tcl" line 22)

Obviously, my Espresso binary does not know what to do with the command and the object_in_fluid_tcl script is not running. I am a bit confused, since I have followed the tutorial step by step. I tried to figure out where in the C-Code the oif_init command is defined, but could find it anywhere. The features in my binaries are: FFTW, Constraints, Area_Force_Global, Volume_Force, Mass, Bond_Angle, LB.

Attached you will also find the config.log of my binary, I hope it helps.


Markus Wink

reply via email to

[Prev in Thread] Current Thread [Next in Thread]