[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ESPResSo-users] Help with cylinder constraint

From: Georg Rempfer
Subject: Re: [ESPResSo-users] Help with cylinder constraint
Date: Sat, 7 Nov 2015 00:02:35 +0100

cylinder.tcl creates a script test.vmd_start.script, which contains amongst other things the following line

    draw cylinder {-2.886751345948129 -2.886751345948129 -2.886751345948129} {2.886751345948129 2.886751345948129 2.886751345948129} radius 1.0 resolution 36

which draws the cylinder. When I ran that yesterday, I did see the cylinder. If you compare your and my VMD cylinde command, you see that your cylinder is very far from the origin. I don't understand why this happens.

On Thu, Nov 5, 2015 at 11:02 PM, Salvador H-V <address@hidden> wrote:
Hi Georg,

Thanks a lot for your answer. 

Your command and the one I am using are very similar. In my case I choose axis 1 0 0 because I want a cylinder along the x-axis. Is this correct?

I tried with your command but still I can see in vmd only the particles but no the cylinder. In fact, in the file 
cilindro.vmd_start.script  I have the following lines:

logfile vmd.log
mol load vsf cilindro.vsf
rotate stop
mol modstyle 0 0 CPK 1.800000 0.300000 8.000000 6.000000
mol modcolor 0 0 Name
imd connect localhost 10000
imd transfer 1
imd keep 1
draw color gray
draw cylinder {97343.75 0.0 0.0} {97968.75 0.0 0.0} radius 0.42 resolution 36

and in the file 
cilindro.vsf i have only the lines
pbc 625.0 625.0 625.0
atom 0:624 radius 0.25 name O type 0 q 0.0

I was wondering if this format is correct. Besides,  I would like to ask you for a basic script in order to corroborate that I am able to see the cylinder.

Thanks a lot in advance


On Thu, Nov 5, 2015 at 12:07 PM, Georg Rempfer <address@hidden> wrote:
b) constraint cylinder axis 1 1 1 length 5 radius 1 center 0 0 0 direction outside type 0
    prepare_vmd_connection test wait 2000 constraints

draws a cylinder for me.

On Thu, Nov 5, 2015 at 5:38 PM, Salvador H-V <address@hidden> wrote:

I am simulating a confined fluid of particles interacting through the repulsive part of the LJ potential.

To confine the system i am using the cylinder constraint implemented in ESPRessSo (Ver. 3.1), however i facing some troubles.

In the initial configuration my 625-particles  (diam_col = 0.4) are located along the x-axis without overlapping  
Part: 618 pos: 618.5 312.5 312.5
Part: 619 pos: 619.5 312.5 312.5

and the cylinder is defined as 
0 cylinder center 312.5 312.5 312.5 axis 1.0 0.0 0.0 radius 0.42 length 312.5 direction -1.0 type 1 penetrable 0

My first problem is related with the radius of the cylinder. 
With the actual value of radius (0.42), the simulation runs fine but the particles seem (in vmd) to be very confined, i.e., it does not appear that particles are inside a cylinder of 
diameter 0.84 (2.1*diameter_col).

If I decrease slightly the radius value, say radius 0.4 => cylinder diameter 0.8 => (2.0*diam_col) then the simulation crash immediately and I do not understand why? 

If understand well the cylinder has a diameter that is twice the particles diameter.  This diameter should be enough for particles to move along the channel. 
Could you help me to clarify this point.

 b)  My second problem is related with the visualization of the constraint in vmd. I follow the 
tutorial.tcl script included in  espresso.

if {$vmd == "yes"} {
     prepare_vmd_connection cilindro start wait 3000 constraints
     imd positions

Then inside the cycle
if { $vmd == "yes" } { imd positions }

With these commands in my script, I am able to launch vmd and visualize the particles but I can not visualize the cylinder. I was wondering what I missing or what I am doing wrong.

Any help would be greatly appreciated.

Thanks a lot in advance



Attachment: cylinder.tcl
Description: Tcl script

Attachment: test.vmd_start.script
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]