[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ESPResSo-users] Compilation trouble

From: Clemens Jochum
Subject: Re: [ESPResSo-users] Compilation trouble
Date: Fri, 20 Oct 2017 23:27:26 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0

I tried to recompile fftw3 from source, but somehow did not manage to make it shared.
Installing libfftw3-dev like in the dockerfile worked.

On 2017-10-20 23:05, Rudolf Weeber wrote:
Hi Clemens,
On Fri, Oct 20, 2017 at 10:35:43PM +0200, Clemens Jochum wrote:
I'm trying to compile the newest espresso development version on my laptop
and I'm running into a problem. Cmake output does not give any errors, but
make only gets to 55%:

    [ 55%] Linking CXX shared library
    /usr/bin/ld: /usr/local/lib/libfftw3.a(assert.o): relocation
    R_X86_64_PC32 against symbol `stdout@@GLIBC_2.2.5' can not be used
    when making a shared object; recompile with -fPIC
    /usr/bin/ld: final link failed: Bad value
    collect2: error: ld returned 1 exit status
    src/core/CMakeFiles/EspressoCore.dir/build.make:3631: recipe for
    target 'src/core/' failed
    make[2]: *** [src/core/] Error 1
    CMakeFiles/Makefile2:1650: recipe for target
    'src/core/CMakeFiles/EspressoCore.dir/all' failed
    make[1]: *** [src/core/CMakeFiles/EspressoCore.dir/all] Error 2
    Makefile:138: recipe for target 'all' failed
    make: *** [all] Error 2

The problem has something to do with glibc, but I'm not sure how exactly.
I'd be grateful for some suggestions.
Most likely, you do not need a custom-compiled fftw.
Take a look in the Dockerfile for your distro to see, what packages we  install 
for the automated testing.

You may also need to take your custom installation of the fftw out of the 
library and include search paths or explicitly select the one shipped with the 
distro in CMake. The stuff in /usr/local typically takes precedence over the 
stuff coming from your distro.

Regards, Rudolf

reply via email to

[Prev in Thread] Current Thread [Next in Thread]