[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ESPResSo-users] problem fom installing the ESPResSo

From: Jean-Noël Grad
Subject: Re: [ESPResSo-users] problem fom installing the ESPResSo
Date: Tue, 16 Apr 2019 13:59:59 +0200
User-agent: Mozilla/5.0 (X11; Linux i686; rv:60.0) Gecko/20100101 Thunderbird/60.6.1


Please copy-paste the first block named "command" from the file /home/zhrq/espresso-4.0.1/build2/compile_commands.json here so we can review which flags CMake is actually using during compilation.

Concerning the MPI_ROOT error message in CMake, this is likely due to the policy change introduced in CMake 3.12 ( Espresso 4.0.1 relies on CMake 3.0, so setting up the environment variable MPI_ROOT="/usr/local/mpich2-1.2-install" will not instruct CMake versions before 3.12 to use MPI 1.2, instead it might just look for the most recent MPI version available. I haven't tried it, but maybe you can instruct CMake to use the 1.2 version of MPI by passing the full path of your 1.2 mpicc compiler with the -DMPI_C_COMPILER=/path/to/mpicc1.2 flag.

Don't forget to reply to this email by clicking "replying to list" and by providing text-based copies of the terminal output instead of screenshots, this helps us a lot!

Best regards,

On 4/16/19 8:59 AM, ricky wrote:

I followed your advice and executed the following commands:

mkdir build2

cd build2

cmake3 -D CMAKE_C_COMPILER=/usr/local/bin/gcc -D CMAKE_CXX_COMPILER=/usr/local/bin/g++ -DCMAKE_CXX_FLAGS="-fPIC" ..


But the same error occurred:

The reason why I add the option “-D CMAKE_C_COMPILER=/usr/local/bin/gcc -D CMAKE_CXX_COMPILER=/usr/local/bin/g++” in the cmake3 command is because I want to use the gcc-5.4.0.

After cmake3 command, I found something strange.

I have installed mpich2 whose version is 1.2, however, the cmake3 seemed to find the version 2.2. I’m not sure whether this is the reason of the problem.

Thanks a million.

Best regards!

Ricky Zhao

reply via email to

[Prev in Thread] Current Thread [Next in Thread]