[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fwd: Re: Errors while installing ESPResSO

From: Jean-Noël Grad
Subject: Re: Fwd: Re: Errors while installing ESPResSO
Date: Wed, 15 Jan 2020 11:59:14 +0100
User-agent: Mozilla/5.0 (X11; Linux i686; rv:68.0) Gecko/20100101 Thunderbird/68.3.0


@Angelos do you also get an ompi_mpi_init error message if you compile and run a small MPI program, like the one attached?

@mkuron do you know if this is normal for espresso compiled with cuda to call rocm/opencl shared objects on a machine with both an AMD chipset and an NVIDIA GPU?


On 1/15/20 11:56 AM, Jean-Noël Grad wrote:
I'm forwarding this to the mailing list as the attached backtrace can be useful to other people. You can click "Reply List" in your email software to reply to address@hidden instead of me, this will help other maintainers following this discussion.


-------- Forwarded Message --------
Subject: Re: Errors while installing ESPResSO
Date: Wed, 15 Jan 2020 11:26:44 +0200
From: Angelos Mourkas <address@hidden>
To: Jean-Noël Grad <address@hidden>

Hello again,

I did as you asked, and it detects NVIDIA graphics card and CUDA drivers without a problem. But when i run "make check" i have multiple errors and some tests that were unable to complete. I guess the MPI service could not be started. Also, if i try to import again espressomd now gives me errors. I have the errors attached.

Best Regards

Angelos Mourkas

On 14/1/20 1:08 μ.μ., Jean-Noël Grad wrote:

According to the CMake output, the HIP compiler was selected to compile espresso for your AMD chipset. If this is indeed what you intended, instructions to install the ROCm SDK can be found at the end of section 2.1.1. Installing requirements on Ubuntu Linux:

If however you intended to compile espresso for the NVIDIA graphics card, you'll need to modify the espresso CMakeLists.txt file. CMake will not detect the main GPU, instead it will try all available GPU compilers on your system and select the first one that works, in your case the HIP compiler. To avoid that, please try this: in /home/agelosmo/Desktop/Simulations/espresso/CMakeLists.txt at line 181, replace "if(HIP_FOUND)" by "if(0)" to skip the HIP compiler. CMake will then try to find NVIDIA CUDA 9.0. If CMake then says it couldn't find a GPU compiler, it means that your installation of NVIDIA CUDA is not properly detected by CMake.

Best regards,

On 1/14/20 8:44 AM, Angelos Mourkas wrote:
Greetings Jean-Noël,

Thank you for the quick respond to my problem. Attached you can find two txt files with the cmake output and the make compilation error. Also i have attached the features error.

At the moment, i am using my nvidia card as the main graphics card. The log files are from 4.1 version of ESPResSO, but i had the same problem with 4.1.2 version.

Thank you very much for your help.

Best Regards

Angelos Mourkas

On 13/1/20 7:16 μ.μ., Jean-Noël Grad wrote:

Compilation errors will interrupt the generation of the Python bindings. You might still be able to import espressomd, but won't be able to import its submodules. Please also note the rocrand library is specific to AMD graphic cards; espresso compiled for AMD will not execute on an NVIDIA card.

To help us diagnostic your issue, please attach a copy of the compilation error to your email, as well as a copy of the CMake output, which contains information about your compiler and libraries, and the version of espresso you're compiling.

Best regards,

On 1/13/20 1:07 PM, Angelos Mourkas wrote:

My name is Angelos Mourkas, a new user of ESPResSO from Greece. I am doing my PhD at the University of Ioannina, Department of Material Science and Engineering.

I have a problem in getting the program to work. I use Ubuntu 18.04 LTS. I believe i have installed all the necessary packages for the program to work. I have a Ryzen 3 2200g (integrated graphic card vega 8) and a discrete graphic card (nvidia 1030gt). I have downloaded and installed nvidia drivers (this is the card i use) and also i have installed the cuda drivers through the commands from the documentation.

Everything is fine until i run the "make" command, where it reports an error concerning <rocrand/rocrand_kernel.h> and another one at

If I ignore the message and continue to the python enviroment, when i enter the command "print(espressomd.features())" it returns the message

Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
AttributeError: module 'espressomd' has no attribute 'features'

Can you please help me installing the program?

Best Regards

Angelos Mourkas

Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]