[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fwd: Re: Errors while installing ESPResSO

From: Angelos Mourkas
Subject: Re: Fwd: Re: Errors while installing ESPResSO
Date: Wed, 15 Jan 2020 15:34:56 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.2.2

Hello all,

Thank you very much for your help @Michael and @Jean-Noel. I have managed to run the program without errors. Unfortunately though, i have to use NVIDIA graphics card, due to other simulation programs running in the same PC that require CUDA Cores.

Anyway glad to be part of your community.

Best Regards

Angelos Mourkas

On 15/1/20 2:54 μ.μ., Michael Kuron wrote:
Hi Angelos and Jean-Noel,

judging from the backtrace, the problem is this: OpenMPI calls into
hwloc, hwloc calls into opencl and opencl is the AMD-provided version
of the library. For some reason, that segfaults. You will have this
problem with any MPI program, not just Espresso. I think you might be
able to work around it by setting the environment variable

Other than that, installing both AMD and Nvidia graphics drivers is
calling for trouble. Both provide OpenCL and OpenGL libraries that may
conflict. I recommend uninstalling all rocm-* packages (or
alternatively, uninstall the nvidia-* packages and remove the Nvidia
card, it's no faster than your integrated AMD GPU).


On Wed, 2020-01-15 at 11:59 +0100, Jean-Noël Grad wrote:

@Angelos do you also get an ompi_mpi_init error message if you
and run a small MPI program, like the one attached?

@mkuron do you know if this is normal for espresso compiled with cuda
call rocm/opencl shared objects on a machine with both an AMD
and an NVIDIA GPU?


On 1/15/20 11:56 AM, Jean-Noël Grad wrote:
I'm forwarding this to the mailing list as the attached backtrace
can be
useful to other people. You can click "Reply List" in your email
software to reply to address@hidden instead of me,
will help other maintainers following this discussion.


-------- Forwarded Message --------
Subject: Re: Errors while installing ESPResSO
Date: Wed, 15 Jan 2020 11:26:44 +0200
From: Angelos Mourkas <address@hidden>
To: Jean-Noël Grad <address@hidden>

Hello again,

I did as you asked, and it detects NVIDIA graphics card and CUDA
without a problem. But when i run "make check" i have multiple
and some tests that were unable to complete. I guess the MPI
could not be started. Also, if i try to import again espressomd
gives me errors. I have the errors attached.

Best Regards

Angelos Mourkas

On 14/1/20 1:08 μ.μ., Jean-Noël Grad wrote:

According to the CMake output, the HIP compiler was selected to
compile espresso for your AMD chipset. If this is indeed what
intended, instructions to install the ROCm SDK can be found at
the end
of section 2.1.1. Installing requirements on Ubuntu Linux:

If however you intended to compile espresso for the NVIDIA
card, you'll need to modify the espresso CMakeLists.txt file.
will not detect the main GPU, instead it will try all available
compilers on your system and select the first one that works, in
case the HIP compiler. To avoid that, please try this: in
/home/agelosmo/Desktop/Simulations/espresso/CMakeLists.txt at
181, replace "if(HIP_FOUND)" by "if(0)" to skip the HIP
CMake will then try to find NVIDIA CUDA 9.0. If CMake then says
couldn't find a GPU compiler, it means that your installation of
NVIDIA CUDA is not properly detected by CMake.

Best regards,

On 1/14/20 8:44 AM, Angelos Mourkas wrote:
Greetings Jean-Noël,

Thank you for the quick respond to my problem. Attached you can
two txt files with the cmake output and the make compilation
Also i have attached the features error.

At the moment, i am using my nvidia card as the main graphics
The log files are from 4.1 version of ESPResSO, but i had the
problem with 4.1.2 version.

Thank you very much for your help.

Best Regards

Angelos Mourkas

On 13/1/20 7:16 μ.μ., Jean-Noël Grad wrote:

Compilation errors will interrupt the generation of the
bindings. You might still be able to import espressomd, but
won't be
able to import its submodules. Please also note the rocrand
is specific to AMD graphic cards; espresso compiled for AMD
will not
execute on an NVIDIA card.

To help us diagnostic your issue, please attach a copy of
compilation error to your email, as well as a copy of the
output, which contains information about your compiler and
libraries, and the version of espresso you're compiling.

Best regards,

On 1/13/20 1:07 PM, Angelos Mourkas wrote:

My name is Angelos Mourkas, a new user of ESPResSO from
Greece. I
am doing my PhD at the University of Ioannina, Department
Material Science and Engineering.

I have a problem in getting the program to work. I use
Ubuntu 18.04
LTS. I believe i have installed all the necessary packages
for the
program to work. I have a Ryzen 3 2200g (integrated graphic
vega 8) and a discrete graphic card (nvidia 1030gt). I
downloaded and installed nvidia drivers (this is the card i
and also i have installed the cuda drivers through the
from the documentation.

Everything is fine until i run the "make" command, where it
an error concerning <rocrand/rocrand_kernel.h> and another
one at

If I ignore the message and continue to the python
enviroment, when
i enter the command "print(espressomd.features())" it
returns the

Traceback (most recent call last):
    File "<stdin>", line 1, in <module>
AttributeError: module 'espressomd' has no attribute

Can you please help me installing the program?

Best Regards

Angelos Mourkas

reply via email to

[Prev in Thread] Current Thread [Next in Thread]