[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[fluid-dev] Weird drum problem

From: Florian Schmidt
Subject: [fluid-dev] Weird drum problem
Date: Sat, 19 Apr 2003 21:57:10 +0200


first of all:

A Bigup to all the people involved with fluidsynth. It's great that you
people spend time and effort on sch a valuable project.

Well, i also have a little problem.. I am the developer of a little
program called "ryth(M)Aid + GUI" (fantastic title, i know ;) look at
rythmaidgui.sourceforge.net for the program details).

Since my soundcard has no onboard synth, i am looking for a software
synth solutionm so my program can play without first rendering into a
file and then using timidity.

This works pretty good actually. I call fluidsynth with this command:

fluidsynth -a alsa -c 8 -z 1024  -m alsa_seq FluidR3GM2.SF2

Then i select the midi port of fluid as midi output device in my

The weird thing is now, that i can't hear any drumsounds. All other
sounds come out fine. I tried different Soundfonts (namely: 


All of these give the same results. I thought: "hmm, maybe these
sondfonts contain no drumsounds" but i remember that it worked once with
the same soundfont and via the oss interface of iiwusynth and the v_midi
kernel module to connect my app with iiwusynth.

Then i thought: "Hmm, maybe it's my app, that's wrong". I tried
different apps. First of all pmidi:

address@hidden:~$ pmidi  -l
 Port     Client name                       Port name
 62:0     Midi Through                      Midi Through Port-0
 64:0     Rawmidi 0 - MPU-401 (UART) 0-0    MPU-401 (UART) 0-0
 65:0     OPL3 FM synth                     OPL3 Port
128:0     FLUID Synth (5214)                Synth input port (5214)

Ok, then i used 

pmidi -p 128:0 some_midi_file.mid

No drumsounds. Everything else is fine and superb..

Then i tried muse

muse -a  

("-a", so audio is disabled and doesn't interfere)

I selected the Synth Input port as midi deveice and everythiogn worked,
except for the drum sounds. I fiddled around with programs and volume
and banks and nothing worked. I restarted fluidsynth one million times..

I don't get it. What could be the problem?

TIA Florian Schmidt

sound clips - http://www.arted.biz/mista.tapas

reply via email to

[Prev in Thread] Current Thread [Next in Thread]