[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] Cannot load soundfont

From: Claus Madsen
Subject: Re: [fluid-dev] Cannot load soundfont
Date: Tue, 11 Nov 2003 02:16:12 +0100
User-agent: Opera7.11/Linux M2 build 406

Mon, 10 Nov 2003 12:37:44 -0800, Josh Green <address@hidden> skrev:

On Mon, 2003-11-10 at 09:22, Claus Madsen wrote:
When trying loading a sf.2 in Fluidsynth-1.0.3 on RedHat 9.0 , 512 MB ram, only this happens:
load GM543kb.sf2
fluidsynth: error: Unable to open file "GM543kb.sf2"
fluidsynth: error: Couldn't load soundfont file
fluidsynth: error: Failed to load SoundFont "GM543kb.sf2"
failed to load the SoundFont
I have tried with different soundfonts, same result.

Thats strange. Make sure you have permissions to read those files. If
you still can't figure it out try running FluidSynth through strace like
"strace fluidsynth soundfont.sf2 2>&1 | less" which will give you a ton
of output but pipe it through less. Then type a "/" character in less
and type a part of the phrase "Unable to open file" blah blah, to search
for that text in the strace output. Look at the strace output before
that error message, it might give you a clue as to why the open is
failing (look for open calls, etc). Hit "q" to quit less. Cheers.

This is what I found:

gettimeofday({1068512382, 361735}, NULL) = 0
brk(0)                                  = 0x8148000
brk(0x8149000)                          = 0x8149000
brk(0)                                  = 0x8149000
brk(0x814a000)                          = 0x814a000
open("/home/cm/.fluidsynth", O_WRONLY) = -1 ENOENT (No such file or directory) open("GM543kb.sf2", O_RDONLY) = -1 ENOENT (No such file or directory) stat64("/usr/share/alsa/alsa.conf", {st_mode=S_IFREG|0644, st_size=8007, ...}) = 0

The path to fluidsynth is:
/home/cm/fluidsynth-1.0.3 and the soundfont is placed in
/home/cm/fluidsynth-1.0.3 /sf2

I cannot see what is going wrong, maybee You can?

Claus Madsen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]