[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] An evil screeching noise when playing

From: Josh Green
Subject: Re: [fluid-dev] An evil screeching noise when playing
Date: Thu, 13 Oct 2005 12:30:19 -0700

Did you try limiting the number of simultaneous voices.  Perhaps there
is an instrument with an extremely long decay time which is causing the
maximum voices to be used which is too much for your system?  Set
synth.polyphony to something lower like 64 or 32.

As to the screeching output.  Have you tried lowering the synth.gain
parameter to see if that can fix the problem?  If there are too many
voices and the gain is too high then the output will go to max (which
eventually leads to silence because the output is completely overdriven,
one huge square wave).

For the crashing problem, try disabling LADSPA in addition to LADCCA.

Do you experience the screeching problem only when playing MIDI files
through FluidSynth?  Does it occur all the time or only with certain
instrument/MIDI file combinations?

Best regards,
        Josh Green

On Sun, 2005-10-09 at 10:20 +0300, Kimmo Sundqvist wrote: 
> Hello
> This is copy-pasted from my Gentoo bugzilla bug at 
> http://bugs.gentoo.org/show_bug.cgi?id=85801
> and I'd like to know if any progress has been made with this, or if anyone 
> has 
> even heard or experienced this.  The text at the beginning of my first 
> bugzilla entry is from this mailing list, so at least the probem is mentioned 
> here before.  To me, this makes fluidsynth totally unusable.
> From the fluid-dev mailing list
> > Recently I got a MIDI interface and a keyboard, and I'm
> > trying them out with FluidSynth to render the MIDI. For most
> > soundfonts I've tried, the first piano instrument (bank 1,
> > program 1) works fine. But when I try almost any other
> > instrument and play a few notes, FluidSynth ends up producing
> > a horrendously loud noise! The only way I can stop it is by
> > changing to a new instrument. It's very weird.
> Reproducible: Always
> Steps to Reproduce:
> 1. Emerge fluidsynth 1.0.5
> 2. Load fluidsynth, load a SoundFont
> 3. Play a midi file to fluidsynth's port
> Actual Results:  
> I head the horrible noise very soon after starting the playback.  When the
> problem was discussed on the mailing list, they found out that:
> a) it has nothing to do with output to ALSA, Jack or file - it happens equally
> in every case
> b) it has nothing to do with the choice of Soundfonts.  I tried this, and this
> was also reported on the mailing list.
> c) it has nothing to do with the MIDI file.
> d) it appears in 1.0.5 but not in 1.0.3.  Will try this out myself soon.
> Later:
> Tested 1.0.6 and it is as if nothing has been fixed.  I loaded the Merlin
> soundfont and tried playing a midi file.
> pmidi blader.mid -p 128:0
> It went ok for two seconds, then came the noise.  After about 10 seconds of 
> noise, it could produce no output, i.e it was totally silent.  I quitted it, 
> reloaded it and the Merlin soundfont.  Tried playing sabre_dance.mid.  It was 
> ok for 10 seconds, then I noticed a clicking that got faster and faster, and
> suddenly the noise (screech, scream, positive feedback loop, whatever) was 
> there again.  It went away after some seconds, and then came back again.  I 
> stopped pmidi, and fluidsynth segfaulted.
> It is as if fluidsynth was doing some kind of echo or chorus, and had a 
> positive feedback loop somewhere, thus resulting in an overload.  Disabling 
> chorus and reverb on the cmdline did nothing to help with the feedback, 
> though.
> Later:
> Tried with -O2 instead of -Os, didn't help.  In sabre_dance.mid, the noise 
> only seems to happen when a certain instrument is playing.  There is 
> something in the midi file that either changes the program for a channel, 
> enables or disables chorus or reverb, changes volume or something, that 
> starts and stops the screech.
> The screech is caused by different instrument or channel in the midi than the
> clicking sound.  The clicking sounds like a vinyl turntable skipping a track.
> After some playing, it just segfaults.  And in other midi files, the noise, 
> once it starts, doesn't stop until I quit fluidsynth, fluidsynth segfaults, 
> or the noise dies suddenly.  After the sudden silence there is no sound 
> output from fluidsynth at all until I quit or something triggers a segfault.
> Later:
> I know that typing 'settings' in the fluidsynth console lists all settings.  I
> see that I can disable both from the cmdline, by --chorus 0 --reverb 0.  But
> typing "chorus 0" or "reverb 0" (or on, off or 1) on the fluidsynth's console
> doesn't change the settings displayed by typing "settings."
> Typing "set synth.chorus.active whoa" sets it to whoa.  I also tried "toilet"
> and "toothfairy" and it didn't complain.  Wonder if it was enabled or disabled
> really.
> Either the synth really doesn't disable chorus and reverb, or it does, but I
> have no way to figure out if it indeed has, and the problem is not related to
> reverb and chorus after all.
> Fluidsynth also randomly, maybe 50% of the time, crashes on startup with
> fluidsynth: fluid_ladspa.c:719: fluid_LADSPA_run: Assertion
> `fluid_settings_getint(FxUnit->synth->settings, "synth.effects-channels",
> &temp)' failed.
> Aborted
> I'll try disabling ladcca and recompiling.
> Later:
> Disabling ladcca in the USE variable didn't help.  Fluidsynth keeps randomly
> segfaulting, and after the Sabre dance starts playing, Fluidsynth's CPU usage
> slowly (in about 10 seconds, from Gnome system monitor) climbs to 99% and 
> stays there.
> Before anyone says anything about my hardware, I think I should mention that I
> can run memtest86 or The Great Internet Mersenne Prime Search's test for 20
> hours with no problems.  I'm leaving this alone now.  If anyone has 
> suggestions or 1.0.7 comes out, I'll maybe have a look and try again.
> -Kimmo S.
> _______________________________________________
> fluid-dev mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/fluid-dev

Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]