[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] System freeze when running latest cvs

From: Josh Green
Subject: Re: [fluid-dev] System freeze when running latest cvs
Date: Tue, 07 Feb 2006 11:56:24 -0800

On Sat, 2006-01-28 at 22:13 -0700, Carmelo Piccione wrote:
> System info below:
> > cat /proc/asound/cards
> 0 [V8235          ]: VIA8233 - VIA 8235
>                      VIA 8235 with ALC250 at 0x1000, irq 201
> 1 [modem          ]: VIA82XX-MODEM - VIA 82XX modem
>                      VIA 82XX modem at 0x1400, irq 201
> alsa-driver-1.0.10
> distro :gentoo amd64 install on a Gateway 7422GX Laptop.
> kernel: linux-2.6.14-gentoo-r2 
> I compiled with debugging enabled
> .
> I can't save the error easily because it freezes as it displays.
> Essentially I run
> "fluidsynth myfont.sf2 -v"
> and it prints out what I believe is an alsa bank / instrument list,
> shows the prompt and freezes about 1 second later. It also says
> something about an alsa sequencer device being intialized. I tried
> using jack instead. The same problem happens. No errors are apparent
> in either case. I suspect its an alsa bug but no other app that uses
> the alsa API freezes the system except for fluidsynth (rosegarden,
> jack, timidity don't). It feels alot like some sort of bizarre race
> condition.
> Thank you,
> Carmelo

Sorry for the delay.  Are you running FluidSynth as root?  If so, it
could be related to a 100% CPU consumption problem.  I just saw that
recently on my laptop.  It seems that if the plug interface to ALSA is
used, then ALSA consumes all of the CPU for some reason.  This can be
avoided by calling FluidSynth like so:

fluidsynth -o audio.alsa.device=hw:0

You mentioned that you tried Jack though, so perhaps that's not the
issue.  If you feel adventurous, perhaps give FluidSynth CVS a try.  I
think there was a fix for AMD 64, that has not yet been released.  If
running as root, try running it not as root to see if you can track down
anything more.
Hope that helps.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]