[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] fluidsynth going dormant periodically? -- SOLVED

From: Ken Restivo
Subject: Re: [fluid-dev] fluidsynth going dormant periodically? -- SOLVED
Date: Wed, 19 Dec 2007 20:27:52 -0800
User-agent: Mutt/1.5.17 (2007-11-01)

The problem was that the interface lo wasn't up.

It was related to ACPI sleep/restore.

Upon restore, lo wasn't being brought up by the /etc/acpi/restore.d/* scripts, 
for some reason. This caused lashd to lose its mind, fluidsynth to be unable to 
communicate with it, and a few other things to fail too, most notably OSC, 
which is how I found the problem.

I did end up disabling lash in my fluidsynth instances, because I don't use it 

I'm now using the latest SVN revision 124 of fluidsynth and so far no problems. 

On Fri, Dec 14, 2007 at 01:18:09AM -0800, Josh Green wrote:
> Hello Ken,
> Sounds like a strange issue.  But as you say, I'm not certain what state
> the version of FluidSynth you have is in, since you also mention CVS,
> which got switched over to subversion a while back.  I'd like to get a
> better idea of how you are running FluidSynth though.  Are you running
> the "fluidsynth" command line shell or are you running it inside of an
> application such as QSynth or another program?  I'm assuming that when
> it goes "dormant" it just never shows up in Jack or ALSA for connections
> (in other words, its not like it just suddenly disappears, but instead
> it never appears).  When this happens, is there anything different in
> the fluidsynth shell or its output (any warnings, errors, etc?).  I
> would think that if both Jack and ALSA didn't show up then there is
> probably an issue occurring in the initialization.
> If you could give the latest release a test though, that would be great!
> You could always revert to your CVS version, if you find there are any
> other issues.  But you could also help the project by letting us know
> about them :)  Best regards,
>       Josh
> On Thu, 2007-12-13 at 20:27 -0800, Ken Restivo wrote:
> > I've noticed an alarming tendency lately for fluidsynth to "go stealth" 
> > sometimes.
> > 
> > Basically I'll start up a couple fluidsynth instances, like I've been doing 
> > every day for almost a year now. But, once in a while, and increasingly 
> > frequently, the instances will NOT show up in JACK, nor will they show up 
> > in ALSA, but the processes *are* definitely running!
> > 
> > So, they kind of go dormant, I guess.
> > 
> > This is with the CVS version from 2007.04.17, yeah yeah I know, it's not 
> > the latest release so probably nobody's too interested in doing anything 
> > about it.
> > 
> > If it were repeatable I'd try the latest version and see what happens. But 
> > it's intermittent so I'm not sure what new problems I'd be introducing by 
> > going to a newer version.
> > 
> > -ken
> > 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]