[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] FluidSynth segfault on Fedora10 AMD64

From: josh
Subject: Re: [fluid-dev] FluidSynth segfault on Fedora10 AMD64
Date: Mon, 11 May 2009 21:40:26 -0400
User-agent: Internet Messaging Program (IMP) H3 (4.1.6)

Quoting Irányossy Knoblauch Artúr <address@hidden>:

Does it also crash with other SoundFont files?

 If it is specific to that SoundFont, if you could send me it off list, that
would be great.
It's not SoundFont specific, I've tried this with many soundfonts,
with the same result. The segfault occures using the
VintageDreamsWaves-v2.sf2 wich is boundled with the source code, but
it seems that the error happens not as frequently as with other
SoundFonts, like this one:

Another thing that might help is if you could run the following commands in
gdb, once it crashes (assuming it crashes at the same line
p voice->sample
p voice->sample->data

Both FluidSynth version 1.0.9 and the latest SVN version crashes on
the same line.
The result is always the following, regardless the SoundFont I use:

(gdb) p voice->sample
$1 = (fluid_sample_t *) 0x0

(gdb) p voice->sample->data
Cannot access memory at address 0x40

I know that there have been issues with 64 bit AMD systems and FluidSynth
before, but I think they are fixed.  There could still be some problem
specific to that platform though.

I'm not sure that this problem is AMD64 specific.
This problem is easily reproducable on my system playing back the
following MIDI file:

If you try to play back this file with the following command,
FluidSynth should crash whitin a few minutes:

while true; do aplaymidi -p 130 01.mid ; done

I just ran this very same test and got the same crash. I've created a ticket and will look into it soon.


Thanks again for reporting this!

Best regards,
Josh Green

reply via email to

[Prev in Thread] Current Thread [Next in Thread]