[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[fluid-dev] Looking for help before I start pulling out my hair

From: Graham Goode
Subject: [fluid-dev] Looking for help before I start pulling out my hair
Date: Thu, 15 Jul 2010 17:04:02 +0200


So, I'm trying, again (I've been trying off and on to get this right
for more than two years now), to get fluidsynth working with portaudio
ASIO. I recently got the latest SVN of PortAudio building with ASIO in
MSVS thanks to a new tutorial from their team, and thought I'd attempt
doing the latest SVN fluidsynth MSVS build as well. That, I found, was

I was informed that CMake would create the necessary configuration to
build with MSVS, so I downloaded and installed CMake, ran the Windows
GUI, configured it for the VS2008 compiler and then got a whole load
of errors and red lines. Most of the red was for libraries I didn't
need (alsa, jack, etc). So I deselected those. I then tried loading
PATH statements for things that I did need,(i.e.the PortAudio build),
but nothing worked. I readup on the FAQ online, and I still do not
know how to get it to find what it seems to be needing.

So, frustrated with all that I then went and installed MinGW/MSYS,
figured out how to build portaudio with ASIO in Msys (thanks to
another good tutorial and someone who'd run into a problem recently
and posted a workaround), then tried fluidsynth using the wiki
Fine until trying ./configure - the file does not exist. So, I ran
autogen.sh to create it

address@hidden ~/User/fluidsynth
$ ./autogen.sh
configure.ac:39: error: possibly undefined macro: AC_CONFIG_MACRO_DIR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:94: error: possibly undefined macro: AC_LIB_PROG_LD_GNU
configure.ac:99: error: possibly undefined macro: AS_HELP_STRING

So, what now...? I spend a day trying to get an environment setup
where I can build and test things, and I get nowhere. I feel as though
I have again completely wasted my time, or that I'll have to invest
another two or three days just learning how to get arround these
errors, time that I'd rather spend on using the software. I just want
to use fluidsynth with ASIO support. So, before I pull out any more
hair... is there someone brave enough to help me?

Sorry for the rant, but as a non-developer I'm now stumped.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]