[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] Need help with CMake for Windows VS 10

From: Pedro Lopez-Cabanillas
Subject: Re: [fluid-dev] Need help with CMake for Windows VS 10
Date: Sun, 25 Jul 2010 14:32:41 +0200
User-agent: KMail/1.9.6 (enterprise 20070904.708012)

On Sunday, July 25, 2010, Jim Henry wrote:
> Another not much of a programmer trying to learn enough about CMake to
> test building FluidSynth for Windows with Visual Studio Express 10. I
> tried to follow Pedro's guidelines for setting up the Windows
> environment but I could have missed something there. I did note that my
> pkgconfig\ directory wound up one level down under lib\ rather than
> being directly under soft\ as Pedro showed it. 

Your "pkg-config.exe" program is found in the path and it finds several 
mandatory packages as glib and gthread, so it seems to work properly anyway.

> Also I haven't set up the 
> things related to libsndfile yet as I was confused by the remarks about
> PortAudio. I was hoping to get a bit further before having to figure
> that part out.

libsndfile and portaudio are both optional and independent. You don't need to 
worry if you don't need their functionality.

> When I run CMake I got the report below. Are the various "not found"
> messages things I need to correct? Or just the error messages in red?
> Any thoughts on where I should be looking for my problems?

Yes, you need to solve several issues.

> Looking for include files StandardHeadersExist - not found.
> ANSI C header files - not found
> Looking for include files HAVE_UNISTD_H
> Looking for include files HAVE_UNISTD_H - not found.
> Looking for DIR in sys/stat.h;sys/types.h;dirent.h
> Looking for DIR in sys/stat.h;sys/types.h;dirent.h - not found.

No problem with the above checks. Many headers only exist on Unix or other 

> Looking for stdlib.h - found
> Looking for signal.h - found

... While other headers exist also on Windows.

> Performing Test _have_inline - Failed
> Performing Test _have___inline__ - Failed
> Performing Test _have___inline - Failed

There is a problem here. I've included a check for three keywords trying to 
find which one is needed for inlining functions, but looks like none is 
supported in VS10. In VS9, "__inline" works, but maybe the check is wrong or 
we need to include another keyword.

> Check if the system is big endian
> CMake Error at C:/Program Files/CMake
> 2.8/share/cmake-2.8/Modules/TestBigEndian.cmake:97 (MESSAGE):
> TEST_BIG_ENDIAN found no result!

Another problem here. This test is implemented by CMake and works in VS9. 
Maybe the VC compiler is not working properly.

> Looking for windows.h - not found

This needs to be fixed, obviously.

> Looking for dsound.h - not found

This header comes from the DirectX SDK. You need the DirectX runtime to run 
FluidSynth on Windows, and the DirectX SDK to compile it or at least 
the "dsound.h" header.

> Looking for include files HAVE_MMSYSTEM_H - not found.
> checking for modules 'glib-2.0>=2.6.5;gthread-2.0>=2.6.5'
> found glib-2.0, version 2.24.0
> found gthread-2.0, version 2.24.0

This means that pkg-config works and finds some mandatory packages.

> package 'sndfile>=1.0.0' not found
> package 'portaudio-2.0>=19' not found
> package 'jack' not found

These packages aren't mandatory. They can be optionally included in windows 
build, if they are found using pkg-config.

Some of the failing checks suggest that the compiler is not working properly. 
I'm not sure about the root cause. Maybe you need to check some environment 
variables required by the compiler. The proper environment for VS compilers 
is provided by a start menu shortcut labeled "Visual Studio XXXX command 
prompt" (or something like that), that opens a cmd.exe window using a .bat 
script. Can you try running cmake-gui from this command prompt and see if 
there is some difference?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]