[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] possible 1.1.3 bug

From: Matt Giuca
Subject: Re: [fluid-dev] possible 1.1.3 bug
Date: Wed, 20 Oct 2010 14:31:05 +1100

Hey Max,

Last time I used fluidsynth to render midis was in january 2010 I
think (I used the version in ubuntu 10.04, don't remember the number).
Everything was fine. However after I updated to 1.1.1 (the current
Ubuntu default), I had the "all instruments are pianos" bug and
decided to update to 1.1.2. After I updated the pianos bug vanished
but it appears another one is here.

Well as far as I know, 1.1.1 was always the version of FluidSynth included with Ubuntu 10.04 (Lucid). When you say "the current Ubuntu default" are you referring to 10.04 still (which is still at FluidSynth 1.1.1)? Because Ubuntu 10.10 (Maverick; which came out a week ago) has FluidSynth 1.1.2 included.

Wait, you say January 2010 -- I assume therefore you mean you used the version in Ubuntu 9.10 (Karmic), which was FluidSynth 1.0.9 according to

This midi file
with this soundfont
renders with lead synth sounding distinctly off-note (however sounding
okay with 8MBGMSFX.SF2)

I can't get to that FTP site (the second link) -- it seems the server is down. Can you upload the SF to dropbox like you did with the ogg file?

I tried downloading and compiling older versions of fluidsynth but
they strangely behave the same way as the new one (I also checked the
1.1.3). Is there something I'm missing?

That's weird. If you can't reproduce the "good" music even with an older version of FluidSynth, then perhaps something else has changed? Maybe the MIDI file, the soundfont, or the parameters have changed since you last recorded the music in January? Have you specifically tried it with FluidSynth 1.0.9?

Sorry I can't be more helpful. Hope these questions help you discover something more about this problem.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]