[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[fluid-dev] No sound on W7 and XP with LoopBe again

From: yanli lei
Subject: [fluid-dev] No sound on W7 and XP with LoopBe again
Date: Sat, 27 Nov 2010 17:29:51 +0800

Did a fresh Windows installation and all setting are in default mode with the same soundbank. I tried to play MDI Input to FS 1.1.1, it does not response, however, the MIDI file could playback as normal on FS engine.

W7 64bits:
LoopBe [not working]
MIDI Yoke [Working using MIDI-OX as a router that redirect from LoopBe Internal [Input] -> Out to MIDI Yoke:  1 [Output] port.]

Before this bug appear, everything was fine as I have recompiled a new build with VS C++ 2008, glib, libsnd and DirectX SDK. It is definitely not a SDK
or directx issue but FS. On Window XP (32bits), FS work only with MIDI Yoke and not LoopBe. Which mean, MIDI Yoke for XP 32bit and LoopBe for W7 64 bits.

To confirm that LoopBe could actually work with FluidSynth GUI, by selected LoopBe Internal MIDI, the application was able to listen to the MIDI event without a glitch.

Anyone encounter the same glitch with LoopBe on W7 64bit?

The info for the available MIDI device:

> info midi.winmidi.device
Type:          string
Value:         default
Default value: default
Options:       In From MIDI Yoke:  1, In From MIDI Yoke:  2, In From MIDI Yoke:
 3, In From MIDI Yoke:  4, In From MIDI Yoke:  5, In From MIDI Yoke:  6, In From
 MIDI Yoke:  7, In From MIDI Yoke:  8, LoopBe Internal MIDI, default
Real-time:     no

Even when I remove MIDI Yoke, it does not solve.

Actually, how do I define the "midi.winmidi.device      default" to "midi.winmidi.device      LoopBe Internal MIDI"?
Tried to type "LoopBe Internal MIDI", the console could only display as "LoopBe".

I wish I could sent MIDI event to MIDI Yoke but under 64bits was not appear to be supported, my Java application do not display that devices except LoopBe.

What do you advice?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]