[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] Major degradation in sound quality & cpu usage going fro

From: Matt Giuca
Subject: Re: [fluid-dev] Major degradation in sound quality & cpu usage going from Ubuntu 11.04 to 11.10
Date: Sun, 6 Nov 2011 14:41:26 +1100

I successfully compiled FluidSynth (1.1.3) on Ubuntu 11.10, and installed it, and the problem went away.

OK so there are four configurations of interest, and it seems that (maybe?) you've only tried three:

1. FS 1.1.3 on Ub 11.04 (i.e., default FS on Ub 11.04)
2. FS 1.1.3 on Ub 11.10
3. FS 1.1.4 on Ub 11.04
4. FS 1.1.4 on Ub 11.10 (i.e., default FS on Ub 11.10)

Am I correct that this is what you're experiencing:

1. Works fine (this is what you were using before this issue came up)
2. Works fine (you just tested this by compiling it yourself)
3. Have not tested
4. Broken

What would be most interesting to me is configuration #3 -- whether FS 1.1.4 is broken on an otherwise normal Ubuntu 11.04. If that is the case, then we can be sure that something in FS broke between 1.1.3 (because no other variables have changed). But I suspect you no longer have access to Ubuntu 11.04, correct?

Now another possibility is that this problem was not introduced by FS between 1.1.3 and 1.1.4, but that you have a problem with the Debian packaged version of FS 1.1.4. Note that the Debian packaged versions of programs are not always exactly the same as the upstream version (that is, the version that the original software developer supplies). Sometimes the code is different; sometimes they simply use different compiler flags.

So a very good thing to try would be see if you can compile FS 1.1.4 using exactly the same process you used to compile FS 1.1.3 on Ubuntu. If that breaks, then we can be reasonably confident that FS 1.1.4 introduced the bug. If that works, then it would indicate that something about the Debian package is breaking. This would all give us a lot of handy information.

In trying the newly-compiled 1.1.3 version out, I first used it without JACK, and it worked as in the prior Ubuntu  release (11.04), with only occasional under-runs (it is only a 933 megahertz machine I'm testing on). 

Then I tried it with JACK, and it also worked (with a few more of the occasional under-runs). 

I will try reproducing the problem without JACK on one of my other machines. 

For the purpose of reproducing the bug, I will supply a MIDI file (which can be played by whatever player you like, such as pmidi, but Rosegarden will work too. 

Have you tried just playing a MIDI file with FluidSynth directly? That's what I do -- just supply the MIDI filename as an extra command-line argument and FluidSynth will play it.

I will supply an audio file (.ogg) of it recorded on Ubuntu 11.04 (FluidSynth 1.1.3), which does not have the problem.  It will be short - less than a minute (so not so large).  It will only be a part of the piece (so I don't give my intellectual property away).

OK. Please also supply an audio file (.ogg) if it recorded on Ubuntu 11.10 (FluidSynth 1.1.4) which does have the problem, so we know whether we are correctly reproducing the bug.

If you have time, I would encourage you to find or create a MIDI file which is just complex enough to reproduce the bug, but which is in the public domain and you do not mind if the world hears it. It would be much easier if we had a public MIDI file which we can work with, so we all have a common test case.

Thanks very much for persevering with this and testing out different builds. I understand how frustrating it is when software breaks, and honestly it is much easier when a user is cooperative, like yourself, in helping to reproduce, rather than just saying "it doesn't work" and giving up.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]