[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] Major degradation in sound quality & cpu usage going fro

From: Aere Greenway
Subject: Re: [fluid-dev] Major degradation in sound quality & cpu usage going from Ubuntu 11.04 to 11.10
Date: Fri, 25 Nov 2011 16:57:49 -0700


All I can say, is I don't understand what has happened. 

There was a system update that installed a new kernal, which may have introduced a significant amount of overhead. 

I carefully re-installed xubuntu 11.10 on my 933 megahertz machine, along with the MIDI/audio software. 

At the last stage (after reproducing the problem), I included your PPA, and installed the updates. 

The piece only plays about 15 seconds, then stops, complaining that there is insufficient processor power to play it.  It seemed that what did play, did not have voices missing, so perhaps the fix is there.  I also verified I had set the polyphony in Qsynth to 48. 

That same piece plays in its entirety on the same machine using ubuntu 11.04, but it gets a total of 5 under-runs during the course of playing the entire piece.  That isn't good, but it's a whole lot better than on xubuntu 11.10, with the fluidsynth fix in-place.  This combination used to play flawlessly. 

Perhaps Canonical has decided to abandon support of people having older, slower machines. 

- Aere

On Fri, 2011-11-25 at 15:41 -0700, Aere Greenway wrote:

It is possible that I forgot to set the polyphony parameter in qsynth down to 64.  That would have produced the observed symptoms. 

Also, there could have been a problem with enabling your PPA during the initial installation of the components. 

I am re-installing, more carefully this time.  I will enable the PPA only at the end, after I have reproduced the problem.  And I will be very, very careful NOT to install the "-dev" version, which rips out JACK. 

- Aere

On Fri, 2011-11-25 at 12:21 -0700, Aere Greenway wrote:

Has something happened to your fix? 

I have been installing it in various 11.10 systems, and it has been working. 

The latest success, was installing it in an Ubuntu 11.10 system, using the Gnome Classic desktop (which you can still download).  That desktop has 20% to 30% less overhead than the Unity desktop, so it is an improvement.  On my 933 megahertz machine, I would get occasional under-runs. 

Unfortunately, they have taken away all of the things that made it easy to use (no more panel icons, no more desktop icons, and especially NO CUSTOMIZATION).  So it's still very bad. 

I decided to do all my music stuff under xubuntu, and installed xubuntu 11.10 (on my 933 megahertz machine). 

After downloading the MIDI/audio software I use, I included your PPA, and installed updates from that. 

Unfortunately, when I ran it, I got many under-runs, and it seems like it is no longer fixed. 

I noticed that it hadn't installed the development files, so I installed that from your PPA - BIG MISTAKE! 

It took out JACK (which I depend upon), and even after removing the fluidsynth dev version, I cannot get qjackctl to work at all, and I don't know why. 

I've tried completely removing things, but still it doesn't work.  I was able to re-install qjackctl, but it won't initialize any more.  I think some libraries it needs have been removed, but I don't know which ones, or how to restore them. 

It looks like I'm going to have to totally re-install the entire system, starting over. 

I really wanted to use 11.10 with your fix, but if it doesn't stay fixed, my only option is to install 11.04.

But if I hide my head in the sand, retreating to 11.04, then I end up with Fluidsynth not working on 12.04, and my entire project is destined for the dust-bin. 

Aere Greenway

On Mon, 2011-11-07 at 11:43 +0100, David Henningsson wrote:
On 11/05/2011 09:12 PM, Aere Greenway wrote:
> David, et al:
> I have not heard back since I reported on performing the test you asked
> me to run.
> I noticed on the website that there are "0 new bugs".
> What process do I need to go through to have this problem evaluated as
> to whether it is officially a 'bug' or not?
> To me, this problem kills my future prospects. The music education
> package I am poised to put out depends on FluidSynth (actually Qsynth,
> which uses it).
> I could distribute my package, and people could get all excited about
> it, but when they installed it themselves (instead of using what comes
> with the package), they would find that the installed version won't even
> play the demo-music, even on a fast machine.
> What I had to go through to compile the older version on the current
> level is not something I could expect a new user of Linux to do.
> There is no path forward if this cannot be fixed. But of course, those
> are the chances I take when I attempt to develop something.
> It would be very helpful if I had some indication of whether or not this
> problem will be addressed, or even looked at.
> I am willing to supply MIDI and audio files you could test it with, and
> verify any fixes.
> Please consider the idea that what I have been doing in the past to
> avoid under-runs, by configuring fewer simultaneous voices (setting the
> polyphony parameter to 64, or even 48 on a slower machine), may be a
> more elegant solution than what has apparently been done in the latest
> release (probably to address that same problem of under-runs).
> I think my planned product could make a big difference in the way people
> learn to play (and compose) music, and I am really hoping FluidSynth can
> be a part of it. It certainly has been a rock-solid, dependable
> component up to now.
> Sincerely,
> Aere Greenway

Hi Aere,

I've been on travel with limited time/possibility to help you. In 
addition, the rebuild I asked you to do was harder than I expected.

But now I'm home again, and here's what I've done now:

I've taken the 1.1.5 package, and added the patch I committed as r435. 
This is because you said something earlier about sound working up to the 
polyphony limit.
I then uploaded the source package to a ppa: 

The ppa probably has finished building when you read this, so can you 
download/install the packages from there and see if it resolves your 
problem? Thanks!

// David

fluid-dev mailing list

fluid-dev mailing list



reply via email to

[Prev in Thread] Current Thread [Next in Thread]