[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] fluid-dev Digest, Vol 198, Issue 16

From: Roberto Panerai Velloso
Subject: Re: [fluid-dev] fluid-dev Digest, Vol 198, Issue 16
Date: Tue, 28 Jan 2020 15:03:24 -0300

It is not a "proper fix" for your problem, BUT I think it might just work until you figure it out: change the shell to login automatically (https://raspberrypi.stackexchange.com/questions/45552/login-automatically-as-root-at-startup) and then run fluidsynth from the root user .profile.


Em ter., 28 de jan. de 2020 às 14:00, <address@hidden> escreveu:
Send fluid-dev mailing list submissions to

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to

You can reach the person managing the list at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of fluid-dev digest..."

Today's Topics:

   1. Problem starting Fluidsynth on a headless RPi (George Poulson)


Message: 1
Date: Tue, 28 Jan 2020 14:05:45 +0000
From: George Poulson <address@hidden>
To: address@hidden
Subject: [fluid-dev] Problem starting Fluidsynth on a headless RPi
Content-Type: text/plain; charset="utf-8"

Hi guys, I'm new to this list so please be gentle! :-)
Apologies in advance if this has been covered before but despite endless
searching I've still not found a way forward

I've recently bought a Nektar MIDI keyboard controller to allow me to learn
to play while keeping a link to my 50+ years experience in computers. I can
plug the keyboard into my laptop and can use <insert software name here> to
listen, via PC speakers, headphones, whatever.

To avoid having to use my laptop every time I just want to practice on the
keyboard for 20 mins or so I have used an RPi3b from my parts box, loaded
up raspbian, fluidsynth and such and if I connect with SSH from my laptop I
can start fluidsynth with the appropriate settings and it all works.

My problem is that I want fluidsynth to start at boot time so that the RPi
becomes a simple 'black box' between my keyboard and headphones, and I am
failing miserably when it comes to getting fluidsynth to start without
manual intervention.

My command line to start fluidsynth is:

*/home/george/fluidsynth -s -i -m alsa_seq -o midi.autoconnect=1 -a alsa -g
4 /home/george/GeneralUser_GS_v1.471.sf2*

[fluidsynth is only in my home directory as it is a local compile because
the repository version is too old]

I have tried using [/etc/rc.local], [cron and @reboot] but I can't make the
*$£*&% thing work as I need it to. Cron/@reboot would be my preferred way
and when I do this, I can log in after booting, see from 'ps waux' that
fluidsynth is running yet there is no audio output. Stopping and starting
fluidsynth manually from a command prompt gets it working fine and the 'ps'
output looks identical!!

*$ps waux | grep fluid*
*george    1115 11.8  5.5  89472 52460 pts/1    SLl+ 14:00   0:00
/home/george/fluidsynth -s -i -m alsa_seq -o midi.autoconnect 1 -a alsa -g
4 /home/george/GeneralUser_GS_v1.471.sf2*

I'm thinking that it perhaps could be because the audio connection (alsa)
isn't being made when fluidsynth is run without a shell, but with little or
no verbose logging from fluidsynth or alsa I am totally stumped!

Please can someone try to help me shed some light on this? I can obviously
provide more diagnostic info if anyone here feels that they can help.

Thanks in anticipation.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.nongnu.org/archive/html/fluid-dev/attachments/20200128/000060fb/attachment.html>


Subject: Digest Footer

fluid-dev mailing list


End of fluid-dev Digest, Vol 198, Issue 16

reply via email to

[Prev in Thread] Current Thread [Next in Thread]