[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ft-devel] Re: [freetype-autohint] Bitstream Vera and tilde

From: August Karlstrom
Subject: [ft-devel] Re: [freetype-autohint] Bitstream Vera and tilde
Date: Fri, 16 Sep 2005 01:45:33 +0200
User-agent: Mozilla Thunderbird 1.0.6 (X11/20050912)

Werner LEMBERG wrote:
If you can reproduce the problem with this application, it is
usually a problem of FreeType2.  Otherwise, it might be a problem
somewhere else.

If I run the command

   ftview -r 96 -f 97 ppem \

tilde displays correctly, but that's at 64 points so it's not much
of a clue.

???  I get a visual tilde for all sizes down to 5pt, using monochrome
display (to make the display worse) and autohinting!  With other
words, this

  ftview -r 96 -f 97 4 Vera.ttf

then pressing `a' and `f', shows something different from a dash,
still resembling a tilde.

OK, now it starts to get interesting. I issue

$ ftview -r 96 -f 97 8 \ /usr/share/fonts/truetype/ttf-bitstream-vera/Vera.ttf

Initially tilde is displayed correctly. This is the rendering I would like to use. If I disable anti-aliasing with `a' it's still a tilde, but with forced auto-hinting (with or without anti-aliasing) all tilde symbols, the single one and the ones above a, n and o turns into a dash/horizontal bar. Everything's not perfect with forced auto-hinting off though: In e.g. `รค' the dots are too far to the left of the `a'. With forced auto-hinting all diacritic marks are correctly centered.

It seems that something is seriously broken at your site.  Which
version of Vera.ttf do you use?  I have the font dated 2003-Apr-16
(the `modified' value in the `head' table).

Same here:

$ ls -l /usr/share/fonts/truetype/ttf-bitstream-vera/Vera.ttf
-rw-r--r-- 1 root root 65932 2003-04-16 16:02 \ /usr/share/fonts/truetype/ttf-bitstream-vera/Vera.ttf

So how do I specify the font rendering (with `dpkg-reconfigure fontconfig') I see initially when I run ftview?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]