[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ft-devel] Third Release candidate for FT 2.2 available

From: Steve Langasek
Subject: Re: [ft-devel] Third Release candidate for FT 2.2 available
Date: Sun, 5 Mar 2006 23:26:52 -0800
User-agent: Mutt/1.5.9i

Hi David,

On Fri, Feb 24, 2006 at 11:20:31AM +0100, david turner wrote:

> I finally fixed the last problems that prevented GNUstep applications
> from working properly in Sarge. Everything now works perfectly on
> this distribution. There are still two ways to get the package:

>  - a pre-autoconf-ed version, ready to be built, is available at


>  - otherwise, use the CVS server:

>   cvs -z3 -d 
> :pserver:address@hidden:/sources/freetype co -r 
> VER-2-2-0-RC3 freetype2
>   cd freetype2
>   sh

> This version works perfectly in Debian Sarge, and couldn't find any 
> problem it introduced.
> The "light" hinting mode works extremely well too and will please any 
> Mac OS X fan with
> "better-shapes-though-blurrier" text :-)

> I'll try to install it on other "old" distributions, but again, I'd 
> appreciate if some volunteers
> would be ready to give a hand.

Well, mailing list delivery is still very spotty for me, but I saw there was
an RC4 tag so I tried that instead.

Anyway, results so far:

- most of the "rogue" applications in Debian etch (i.e., versions built
  against freetype 2.1.10) appear to work ok with 2.2rc4; this includes
  xpdf-reader, evince (uses poppler), and fontconfig-using applications.
- gimp segfaults in pango_fc_font_create_metrics_for_context(); this version
  of pango is built against freetype 2.1.10, but it's pango 1.10.3 and that
  was reported to be new enough that it no longer uses the freetype internal
- I'm told sdl-ttf from testing/unstable breaks down, either with a font
  error or a segfault.  I haven't confirmed this myself yet, but given that
  this is still one of the "rogue" libraries, I suppose it's nothing to
  worry about; I haven't checked the build of sdl-ttf from sarge yet, but
  I'm hopeful it will work since it was built against 2.1.7.
- gnustep-back from sarge (i.e., built against freetype 2.1.7) fails
  stupendously with 2.2rc4, spitting out the following error repeatedly:

  2006-03-05 23:14:17.000 ViewPDF[31022] Error when loading 

  This is when calling FT_New_Face().  I haven't tried to debug this yet
  because setting gnustep up to run under gdb is painful; I'll probably take
  a look at gimp/pango first instead.

If you or anyone else has specific suggestions for testing/debugging, I
would welcome them.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]