[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnucash and G-Wrap 1.9

From: David Hampton
Subject: Re: Gnucash and G-Wrap 1.9
Date: Sun, 31 Jul 2005 19:34:59 -0400

On Sat, 2005-07-30 at 18:04 +0200, Andreas Rottmann wrote:

> Yes and no. The runtime is parallel-installable, so you can keep
> applications/libraries built with 1.3 installed when upgrading G-Wrap
> to 1.9, but the development environment is not. This is not a problem
> however, due G-Wrap 1.9 provides compatibility with 1.3.

This must have been a problem in my setup.  I had 1.3.4 installed
in /usr and 1.9.6 installed in /opt.  I thought I had set the
PKG_CONFIG_PATH and LD_LIBRARY_PATH variables properly, but I must have
been getting something from the wrong version.  I saw the exact same
error as before when I compiled against 1.3.4, removed 1.3.4 completely
from my system, and then executed against 1.9.6.

The good news is that if I remove 1.3.4 from my system and compile
against 1.9.6, the code compiles and runs cleanly with no changes needed
to gnucash.

What's your planned timing for replacing glib-1.2 with glib-2.0 in g-
wrap?   This is the last reference to glib1/gtk1/gnome1 in the (in
progress) gtk2 port of gnucash.  I tried modifying the g-wrap configure
file and replacing all the pkg-config references to 'glib' with
'glib-2.0'.  G-wrap compiles without any error, and the gtk2 port of
gnucash runs just fine.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]