[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] Re: GCL HTTP

From: Camm Maguire
Subject: [Gcl-devel] Re: GCL HTTP
Date: 17 Jun 2005 10:35:40 -0400
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2


Yes, we are only waiting on 2.6.7 for Windows gcl-tk.  If axiom is
going the web route instead, we could push it out asap.  I'm still a
little unclear as to which of the gcl-tk/webserver options axiom will
be using for docs and graphics.  If we can clarify this, it would help
me plan official gcl releases.

Take care,

"Bill Page" <address@hidden> writes:

> Kai,
> You are right that it is GCL problem. As I said previously
> this only works with GCL tagged version VERSION_2_6_7pre
> (and probably also GCL CVS head, but I haven't tested this).
> If you are still using GCL 2.6.6 then you also need the
> patch that Camm gave here:
> http://lists.gnu.org/archive/html/axiom-developer/2005-04/msg00141.html
> I have run this code on both Fedora Core 3 x86-64 and on
> Windows XP but I don't know anyone who has tried it on
> a MAC. Let me know how it goes.
> BTW, if you haven't started using the axiom archives yet,
> I think you will find that it contains a lot of useful
> stuff. For example, at
> http://lists.gnu.org/archive/html/axiom-developer
> try this:
> http://lists.gnu.org/archive/cgi-bin/namazu.cgi?query=%22simple+web+serv
> er%22&submit=Search%21&idxname=axiom-developer&max=10&result=normal&sort
> =date%3Aearly
> Also, if you haven't yet subscribed to the gcl-devel email
> list, you might also be interested to know that there is has
> been some recent and ongoing work on the GCL on OS/X.
> http://lists.gnu.org/mailman/listinfo/gcl-devel
> Regards,
> Bill Page.
> --------
> On June 17, 2005 8:22 AM you wrote:
> > I tried to figure out what the problem might be and this is
> > what I found so far. The problem is that GCL does not create
> > a socket.
> > Suppose I type
> > 
> > GCL> (defun server (stream) (close stream))
> > GCL> (setq s (si::socket 11111 :server #'server))
> > 
> > Then GCL successfully creates a socket, according to netstat.
> > If I connect to localhost:11111 with netcat that also works,
> > according to netstat. Nevertheless (si::listen s) and (listen s)
> > always return NIL. Even if I type something in Netcat and send it.
> > This explains why your code does not work on my system. Ignoring
> > (listen s) and just reading from s does not work, by the way.
> > An end-of-file condition is signaled. Writing to s, e.g.
> > (format s "Text"), provokes an error message ("Error in FORMAT
> > [or a callee]: error writing to socket: errno= 57") and throws me
> > into the debugger.
> >
> > To me this looks like a GCL/Mac problem.

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]