[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gcl-devel] Porting Femlisp (second trial)

From: Nicolas Neuss
Subject: Re: [Gcl-devel] Porting Femlisp (second trial)
Date: Wed, 28 Sep 2005 16:38:13 +0200
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/21.4 (gnu/linux)

Nicolas Neuss <address@hidden> writes:

> Camm Maguire <address@hidden> writes:
>> Greetings!
>> Please try gclcvs -50, now in unstable (should be in testing soon).
>> 1 and 3 are fixed therein.
> Fine.  I'll wait for testing (i.e. I'll try again in two weeks).  I tried
> to apt-get gclcvs/unstable but there was a dependency on libgmp3c2 which
> would have required the removal of many packages (e.g. axiom) so I
> refrained.

I tried again and after an update of my Debian system even installing
gcl/unstable worked.  Now it looks as if missing EQUALP-hash tables is the
essential problem which prevents Femlisp from running with GCL[1].

I also encountered the following bug.  I have a file debug.lisp containing
both package definition and code using this package in the same file.
Compiling works fine, loading the result works fine, too.  However, if I
restart gclcvs and load the object file an error is thrown:

    address@hidden:~/CL-HOME/femlisp/src/basic$ gclcvs
    GCL (GNU Common Lisp)  2.7.0 ANSI    Sep 10 2005 12:05:30
    >(compile-file "debug.lisp")
    address@hidden:~/CL-HOME/femlisp/src/basic$ gclcvs
    >(load "debug.o")
    Loading debug.o
    Error in EVAL [or a callee]: The package named FL.DEBUG, does not exist

Yours, Nicolas.

[1] Unfortunately, I use those (with keys being short lists of double-float
vectors) at several places and it would be awkward to work around it.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]