[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Geiser-users] REPL dying when using autodoc and the Mailutils module

From: Mark Skilbeck
Subject: [Geiser-users] REPL dying when using autodoc and the Mailutils module
Date: Fri, 25 May 2012 15:40:47 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

I've recently tried using the GNU Mailutils library. It comes with
some bindings for Guile, too! Anyway, after using it briefly with
Geiser as my scheme-mode, I ran into an issue that I'm not quite sure
how to alleviate.

After evaluating this piece of code[1], the REPL will terminate and
give me the message "It's been nice interacting with you!". This
doesn't happen immediately, but only after I start navigating through
the code, and more specifically when I interact with some Mailutil
symbols. So, if I were to navigate to mu-mailbox-get-message in the
supplied code, and move to the end of the symbol, the REPL would
terminate. I believe it's related to Autodoc, though I can't be quite
sure. Turning off geiser-autodoc-mode does prevent the issue.

Of course, my question isn't "What's wrong with Geiser?" as Geiser has
worked beautifully for me and I haven't noticed this issue with other
modules. My question is: how can I debug this and maybe fix it? Any
tips/hints would be greatly appreciated.

(use-modules (mailutils mailutils))


(let* ((mbox (mu-mailbox-open "~/Mail/mbox" "r"))
       (mbox-count (mu-mailbox-messages-count mbox)))
  (let loop ((i 1))
    (cond ((< i mbox-count)
           (let* ((msg (mu-mailbox-get-message mbox i))
                  (hdr (mu-message-get-header msg "From")))


P.S. If you would like to replicate the issue, you will need to use
the latest code from the Mailutils Git repo[2], as the latest "release"
of Mailutils doesn't compile! Some "release", eh?


- mgsk.

if all you young men / were fish in the water 
how many young girls / would undress and dive after

reply via email to

[Prev in Thread] Current Thread [Next in Thread]