[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Getfem-users] Parallelization of getfem

From: Roland Stoffel
Subject: [Getfem-users] Parallelization of getfem
Date: Thu, 12 May 2011 14:35:22 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110424 Thunderbird/3.1.10

Dear all,

i tried to install getfem in the parallel version with the configure script
./configure --enable-paralevel=2
Everything works, but at the point where configure checks the mpi i get the error message:

checking for SelectQueueOneWay in -lmetis... yes
Building with METIS (use --enable-metis=no to disable it)
checking for MPI_Test in -lmpich... no
checking for MPI_Test in -lmpichcxx... no
checking mpi/mpi.h usability... no
checking mpi/mpi.h presence... no
checking for mpi/mpi.h... no
checking mpi.h usability... yes
checking mpi.h presence... yes
checking for mpi.h... yes
Building with MPI (use --enable-mpi=no to disable it)
checking for dgetrf_ in -llapack... yes
You are using MPI! Trying to build a parallelised version of getfem (require METIS)
checking for METIS_PartMeshNodal in -lmetis... no
configure: error: Parallel getfem requires the METIS ( ) library
 ----------> Please add the path to libmetis.a to the MPI_LIBS variable.

So, what's wrong?
I have install metis with the debian repository (libparmetis-dev) and all the metis-libaries(libmetis.a, libparmetis.a ...) are in /usr/lib/. I have also set the MPI_LIBS Variable to this path but i get the same error message.

Can anyone help me???

Thanks in advance and best regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]