[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Compilation problem with mumps

From: pierre.gosselet
Subject: Compilation problem with mumps
Date: Mon, 24 May 2021 17:48:01 +0200
User-agent: Evolution 3.38.3-1

Dear all,
I am working on a cluster and I need to compile getfem and most of its

I have a hard time compiling the mumps support. I know close questions
were already asked but I did not find the answer. Sorry if I missed it.
I compiled sequential mumps without trouble, examples work fine.

I tried to configure getfem with:
./configure --enable-mumps --with-mumps-include-
dir="$MUMPS_DIR/include" --with-mumps="-fopenmp -lsmumps -lmumps_common
-ldmumps -lcmumps -lzmumps -lpord -lesmumps -lscotch -lscotcherr -
llapack -lmpiseq -lblas -lpthread" --with-pic

I always have the following problem:
checking for library containing smumps_c... no
configure: error: The function smumps_c couldn't be found in the
provided MUMPS libraries.

The --with-mumps is inspired by the compilation line for mumps examples
(I have copied the libseq includes file in the include directory).
All the libraries are in the $LD_LIBRARY_PATH, but I also tried with
the full path. $MUMPS_DIR is well defined. I also tried with the mumps
module provided by the cluster's administrator (with adapted include),
same problem.

Can anyone help me ?

best regards

Pierre Gosselet
CR CNRS (research agent), HdR
LaMcube, Univ.Lille/CNRS (UMR 9013)/Centrale Lille
Cité scientifique, Bat. Esprit, bureau S1.74
Avenue Paul Langevin, 59655 Villeneuve d'Ascq Cedex
Tel: +33 320434349

reply via email to

[Prev in Thread] Current Thread [Next in Thread]