[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compilation problem with mumps

From: Konstantinos Poulios
Subject: Re: Compilation problem with mumps
Date: Tue, 25 May 2021 22:24:52 +0200

Dear Pierre

This is how I compile sequential getfem on our cluster (running some version of Scientific Linux):

I put all dependencies (symbolic links actually) into two folders:

then I configure getfem with

./configure --prefix=/some_installation_path/getfemseq BLAS_LIBS=-L/some_path_with_dependencies/lib -lopenblas -lpthread CPPFLAGS=-I/some_path_with_dependencies/include LDFLAGS=-L/some_path_with_dependencies/deps/lib LIBS="-lmumps_common -lpord -lmpiseq -lmetis -lesmumps -lscotch -lscotcherr -lpthread -lgfortran" --with-optimization=-O2 --with-pic --disable-matlab --enable-python --enable-mumps

My "include" and "lib" dependencies folders contain:

This is the minimal amount of files that GetFEM links to. Depending on how you compile mumps, you might get slightly different dependencies, but I think you get the idea.

If you are still stuck after this, just let me know and I can tell you how to debug the configure error more systematically.

Best regards

On Mon, May 24, 2021 at 6:32 PM edgar <> wrote:
Hi, Pierre. Disclaimer: I haven't been able to compile the test suite
correctly (take my advice with reserves).

The sequential libraries of MUMPS usually have _seq before the .o . I
can imagine that you already checked that you have the right libraries.
By the looks of it, you are using the parallel version, but I don't dare
to draw such conclusion. This comes from the configure file, and you
might want to try it:

     "-lsmumps_seq -ldmumps_seq -lcmumps_seq -lzmumps_seq"

I remember that I was able to hijack the library files with a variable
(MUMPS_LIBS?), but I am sure that the developers will have much better
advice than this.

Bonne chance!

On 2021-05-24 15:48, pierre.gosselet wrote:
> Dear all,
> I am working on a cluster and I need to compile getfem and most of its
> dependency.
> I have a hard time compiling the mumps support. I know close questions
> were already asked but I did not find the answer. Sorry if I missed it.
> I compiled sequential mumps without trouble, examples work fine.
> I tried to configure getfem with:
> ./configure --enable-mumps --with-mumps-include-
> dir="$MUMPS_DIR/include" --with-mumps="-fopenmp -lsmumps -lmumps_common
> -ldmumps -lcmumps -lzmumps -lpord -lesmumps -lscotch -lscotcherr -
> llapack -lmpiseq -lblas -lpthread" --with-pic
> I always have the following problem:
> checking for library containing smumps_c... no
> configure: error: The function smumps_c couldn't be found in the
> provided MUMPS libraries.
> The --with-mumps is inspired by the compilation line for mumps examples
> (I have copied the libseq includes file in the include directory).
> All the libraries are in the $LD_LIBRARY_PATH, but I also tried with
> the full path. $MUMPS_DIR is well defined. I also tried with the mumps
> module provided by the cluster's administrator (with adapted include),
> same problem.
> Can anyone help me ?
> best regards
> pierre

reply via email to

[Prev in Thread] Current Thread [Next in Thread]