[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gforth] package in openbsd is old -- 0.6.2

From: Joel Rees
Subject: Re: [gforth] package in openbsd is old -- 0.6.2
Date: Mon, 24 Nov 2014 22:19:24 +0900

On 11/24/14, Joel Rees <address@hidden> wrote:
> 2014/11/24 14:05 "Joel Rees" <address@hidden>:
>> Hi,
>> 0.6.2 installed from the openbsd packages.
>> I thought I'd take a try at building 0.7.3 and I'm running into
>> errors. I would, of course, appreciate any clues you guys might have.
>> In configuration, I get
>>     configure: WARNING: The (old) lib.fs foreign function interface
>> needs either libffi or the ffcall libraries
>> but both libffi and ffcall openbsd packages are installed.
> Using the find command, I've confirmed that ffi.h is under
> /usr/local/include .
> I've tried
>     ./configure --includedir=/usr/local/include
> and several variations with no change. Also tried the -I option to make.

Installed emacs and tried the following:

    export CFLAGS="-I/usr/local/include"
    export LDFLAGS="-L/usr/local/lib/:/usr/local/libexec/"
    export LTDL_LIBRARY_PATH=/usr/local/lib/

And the results are not quite the same. Now it sort-of finds ffi.h,
says it is useable, but then says it is not present. Accepted by the
compiler, rejected by the pre-processor.

Seems to find libltdl.h or whatever that was, too, but then libtool
fails during make.

Attaching the output of ./configure and make combined in
buildrecord.text, with the config.log .

Joel Rees

Attachment: buildrecord.text
Description: Text document

Attachment: config.log
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]