[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gforth] GForth on Raspberry Pi - Serial port

From: Anton Ertl
Subject: Re: [gforth] GForth on Raspberry Pi - Serial port
Date: Wed, 12 Aug 2015 18:18:41 +0200
User-agent: Mutt/1.5.18 (2008-05-17)

On Wed, Aug 12, 2015 at 09:19:40AM -0400, Mario Beaulieu wrote:
> Hi,
> I installed GForth on my Raspberry Pi (Linux, ARM). I have difficulty when I 
> try to access the serial port.
> First, I tried to include "Serial.fs" from the "contrib" directory. It gave 
> me an error because it could not find the word "ioctl". After some research, 
> I found it in "Syscalls386.fs". 
> So I included it too, but syscalls could not find the word ".d" which is in 
> assembler. I found it in "asm.fs" in the "/arch/386" directory. Note that 
> ".d" is not defined in "asm.fs" in the "/arch/ARM" directory, which would 
> have been my first choice since that's the processor I'm working on.
> I also had to include "strings.fs" eventually.
> So I managed to compile without error, but when I run it (serial_open), I get 
> an error "609: instruction not allowed" (translated from French - instruction 
> non permise). 
> I suspect that I'm not including the right files.
> Is syscalls386 supposed to work on an ARM architecture or is it only for x86?

The version you are using is only for the 386 architecture.  It has
been replaced in the development version with a portable version:

Try using that.

- anton

reply via email to

[Prev in Thread] Current Thread [Next in Thread]