[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gforth] reposition-file stack problem on ancient linux

From: Ethan Grammatikidis
Subject: [gforth] reposition-file stack problem on ancient linux
Date: Sun, 25 Feb 2018 11:33:07 +0000

hello! i'm just getting into forth, i'm very enthusiastic about it at the 
moment. i think it's the language i should have got into when i was a kid in 
the 80s. :) i have this pretty little ibook i like to use sometimes. its hard 
drive is dead now, so i use an ancient linux live cd, from 2004. i was happy to 
find the latest stable version of gforth compiles and runs on this system, 
which has kernel 2.6.9, and gcc 3.4.3.

i like messing about with pixels and framebuffers, so i've made that my first 
little project with the language. i ran into trouble as soon as i tried to use 
reposition-file. its stack comment in prim indicates it takes two elements from 
the stack:

reposition-file ( ud wfileid -- wior )  file    reposition_file

if i try to use it that way on the ibook, i get an underflow message:

10 fbid .s <2> 10 268779816  ok
:16: Stack underflow

there's nothing after "Backtrace:". fbid refers to an open framebuffer file 
which can be written to to display stuff. oh, now i see file-position returns 0 
0 even after filling the screen. that can't be right either. screenshot for 
file-position attached.

i've made more than my share of bad bug reports in my time, so it could be me, 
but i'm guessing it could be an incompatibility with this ancient kernel and 
libc. i almost hope it's me, but i've used linux for over 20 years and got 
quite pessimistic about it.

The lyf so short, the craft so long to lerne. -- Chaucer

Attachment: file-position_problem0-500.jpg
Description: JPEG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]