[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gforth] Accented characters

From: Mario Beaulieu
Subject: [gforth] Accented characters
Date: Thu, 3 May 2018 22:14:32 -0400


The problem I'm having might not have anything to do with GForth, but let's 
see. I'm running GForth on a Raspberry Pi (Linux).

I have a GForth program (notification.fs) that sends notifications to my cell 
phone. The problem I have is that it replaces accented characters (à, è, é, 
etc.) with question marks but only if I run it from the command line , like:
                 GForth notification.fs

What the file notification.fs does, is compile the necessary words, the main 
one being SendNotification, and the last line sends a message, like:
                 s" àéèeeeee"  SendNotification

If I run it from the command line, it replaces the accented characters, but if 
I start GForth first and paste the content of notification.fs, it works 

Even weirder, if I 'redo' the last line right after running it from the command 
line, it works!

The character encoding is UTF-8. I tried with ISO8859-1, with the same result.

Any idea?


Mario Beaulieu

Envoyé de mon iPad

reply via email to

[Prev in Thread] Current Thread [Next in Thread]