[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gm2] Building gm2 for windows with mingw

From: Vanessa Bodard
Subject: [Gm2] Building gm2 for windows with mingw
Date: Tue, 4 Nov 2008 14:07:48 +0100

Hi all,

I'm currently trying to build gm2 for windows with mingw.
I updated the script I found there

But I have some problems during the building of binutils. The make
fails with this error:
~/mingw/source/binutils-2.13.90-20030111-1-src/ld/ldlex.l: In function
~/mingw/source/binutils-2.13.90-20030111-1-src/ld/ldlex.l:615: error:
`yy_current_buffer' undeclared (first use in this function)
~/mingw/source/binutils-2.13.90-20030111-1-src/ld/ldlex.l:615: error:
(Each undeclared identifier is reported only once
~/mingw/source/binutils-2.13.90-20030111-1-src/ld/ldlex.l:615: error:
for each function it appears in.)

I watched into the file and found that yy_current_buffer was declare
in upper case.
I tried to change it but I think the file is created during the make.

I also found that it was a common error and that it seems to come from flex.
The solution proposed was to take the older flex version.
But as flex come with binutils, I don't know how to change it.
Does anybody has an idea on how change the version flex?

Also, when I tried to update the script, I had chosen a more recent
version of MinGW files.
But it fails on the make of binutils with the followinf error message:
"make: *** No targets specified and no makefile found.  Stop."

Does anybody tries to install gm2 with mingw?

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]